Invalid SSL Certificate error

Hello, please I can’t load my website over HTTPS as it shows invalid certificate. The domain is working well, but the subdomain is not working over HTTPS. I already added to cloudflare (which should cover for the subdomain), but I think I mistakenly self-signed before activating cloudflare, any help would be highly appreciated. Thanks.

I forgot to add that the HTTPS connection worked flawlessly for a few hours, just stopped suddenly.

I just successfully self-signed with sslforfree, checked my status with SSL labs and whynopadlock and everything checks green, but it still doesn’t work on browser.
Link to whynopadlock test:


After installing your certificate…

Once the certificate has been installed, you can verify it has been installed correctly using an SSL checker. Using an SSL checker is the best way to find out whether the certificate installation was successful.

By now, you can also try to verify it’s installed correctly by visiting https:// . If you see a green lock in your browser’s address bar, that means the certificate has been installed correctly.

If you do not see a green lock, here are some things to check:

  • If you see a red warning page, your browser may not have checked the new certificate. Some browsers (notably Google Chrome) remember the certificates of websites for some time, so it may take a few hours for your browser to see the new certificate.
  • If you are redirected from the https:// page to http:// , your website is forcing people to the non-https version of your site. Most of the time, the script has a setting for the “website URL” or something like that. If you change the website URL to https://, you should be able to see the website over https.
  • If your website is using the https:// URL but the address bar is still white, it means that some of the stylesheets, scripts or images on the page are still using http:// URLs. You need to find those URLs and make sure they all use https as well.