Infinity free SSL DNS didn't change even after 24 hours

manualias (

Error Message No CNAME records could be found on the subdomain. Please note that DNS changes can take up to 24 hours to take effect.

I created a ssl certificate yesterday and added the details in Cname records. But its still showing the error mentioned above. Any solution?

Are you sure?

Could you send us an screenshot of the CNAME records or Control panel?

Thanks for the quick reply

You are using Cloudlare meaning you’ll have to create/add those CNAME records directly on Cloudflare.

Annotation 2020-07-22 052838

If you are using nameservers from other services like web hosting then that means any DNS records you create here will be ignored.



manualias (

Error Message The CNAME record is not pointing to the right destination (current value: Please note that DNS changes can take up to 24 hours to take effect.

Trying to get SSL certificate from yesterday. Added the domain in free SSL certificates section and also added the CNAME records. But even after 24 hours, it shows the above mentioned error

Please help me out! I am completely stuck here!!! Thanks in advance

You are using cloudflare nameservers.

You must add those cname records thru/using the cloudflare dns manager/dashboard rather than using the cname record manager on infinityfree cpanel which is not working since you are not using infinityfree nameservers.

Edit: Please do not create a multiple topics with the same issue :slight_smile: Thanks to MOD-BayoDino for splitting the topic


Thanks for the response. I am no longer using the cloudflare accounts. I removed the cloud account yesterday itself and then requested for the SSL Certificate and added CNAME records. It’s not the same issue if you consider these changes.

Hi, you will need to remove the cloudflare namesevers. Change your nameservers again to and or infinityfree nameservers. Then you will need to wait at least for an hour. After waiting, remove and add the CNAME Records again using the InfinityFree cpanel. Then wait.


Thank you for responding back! Now I get it :slightly_smiling_face:
I will try to do the same. Thank you so much for the help.
Have a great day :blush:

1 Like

Hi @Admin, @katufo
Now I am getting another error!

Error Message: There are currently 1 TXT record(s) on the verification subdomain. Please remove any TXT records and only set the CNAME record. Please note that DNS changes can take up to 24 hours to take effect. The required CNAME record could not be found. Please note that DNS
changes can take up to 24 hours to take effect.

I looked into other members who had similar issues but, its not mentioned how exactly he fixed it.
Could you help me on that?

When did you add or change the cname records and when did that error occured?

Maybe, just wait for it to propagate cause you have just added it recently.


The problem got fixed automatically after few hours. Thank you so much for your help

Please make the topic solved.

Goodluck with your site!!

Maybe it is simple, but for the novice, could you explain:

  1. What should be placed in the [SOURCE] field (assuming _acme-challenge only)?
  2. What should be placed in the [domain] field: (assuming the external domain name?)?
  3. Is it possible to create SSL with infinity assigned subdomain?
  4. What should be placed in the [DESTINATION] field when creating records? How to find the cryptic string which is listed in screenshots and in Free certificate check?

When I purchased the domain name, I assigned infinity name servers for it. How do I check which actual name server is storing the domain name and which is the primary name server?

I’m here so i’ll answer,

1, _acme-challenge (So yes)
2, Yes, your domain
3, Not with the InfinityFree SSL, and due to spam, Lets Encrypt probably won’t give it, but apparently works.
4, The destination will be in the SSL tool, it will be a bunch of random letters, followed by

You can use to check Nameserver records, or use linux CLI dig.


If you click the blue “How to create CNAME records […]” text in the screenshot, you’ll be brought to an article which explains step by step how to set them.


Useful info - many thanks.
I have the same ‘remove 1 TXT record and 24 hour DNS sync’ messages, so also waiting to see if mine also resolves itself (as above) :slight_smile: :mask:

Screenshot of my CNAME records but I didn’t add all! Its system generated records. My certificate also is not working right now!
What should I do?

Hi all I’m so new to this stuff can you guys check if is everything ok with this.
I added CNAME yesterday around 6pm.