Images are not loading getting 301 ,404 error

In this website artup.rf.gd , http://thebuildupworld.rf.gd/ and other website of different account i am getting same error of images are not loading after appling theme,
normal image from media is working but the images which has url links are not working ,
i created a different account just to test if it works fine there but im getting same problem in new account aswell.
i spent 5 days searching for solution still no help , please suggest some soultion for this issue.
i am getting error 301 Moved Permanently and
404 Not Found.

What issue?

Write clearly

4 Likes

Please check the website now. I am trying out all the themes, and this theme in the picture is working a bit better because all its images are stored in the media library. However, most of the themes, which have image URLs, are not working. They are giving ‘301 Moved Permanently’ and ‘404 Not Found’ errors. Please check the website now.

Which one(s)?

Which one?

I am not obligated to help you since you did not even bother to write clearly.

5 Likes

i mean this website http://thebuildupworld.rf.gd/ which you posted the pic of, now i have changed the theme again to which i am getting the error,
i wrote the issue clearly i am unable to load the images in my website which have image url and im getting the error They are giving ‘301 Moved Permanently’ and ‘404 Not Found’ errors. but the images in the media are loading fine like the previous them you posted screenshot of.

have you added any rules to your .htaccess ? check if someone strange is happening with that

1 Like

Check your url

image

Definitely not valid

5 Likes

No i didnt edit this file at all

How can I correct this? Please guide me.
right now i have set permalink to postname

Your database is messed up.
Is this file present?

image

2 Likes

Yes, there are so many contact-heroes. How do I fix the database? I haven’t touched it at all. All I did was set up the website and then installed themes one by one to test them, but none of them worked properly.

Do you by any means migrated from a old WP multisite install?

(Just for clarification, the /sites in the upload url is a good sign of an old multisite install.)

3 Likes

No, I haven’t. I was working on a WordPress website, https://artup.rf.gd/. I wanted to clear all the pages and posts and start anew, so I used WP Reset to delete all the posts. That’s when the problem started.
So, I created another website from the same account to see if the problem would go away, but I still had the same issue.
Then, I created a new, fresh account and created a website from it. However, after changing the theme for the second time, I encountered the same error. My images are not showing because the image URL cannot load.
I’ve spent 5 days trying everything, but I still have no clue what the problem is.

Judging from how your site tries to load data from websitedemos.net (but end up failed due to screwed URLs), this is a good sign that you’re trying to use a junk theme that don’t even know how to present demo content to clients.

Moreover, our hosting have pretty strict CORS settings, so external links might not work.

Is that a plugin? If so, it’s a pretty bad practice.

2 Likes

What is the solution for this? It used to work before, but now I’ve suddenly encountered a problem. Because of this issue, I can’t use any theme properly. When I click on the link from the inspect element HTML, it directs me to this link: https://artup.rf.gd/"https:/websitedemos.net/dental-08/wp-content/uploads/sites/906/2022/10/testimonial-150x150-1.jpg/. That’s why it’s not working. But it should look like this: https://websitedemos.net/dental-08/wp-content/uploads/sites/906/2022/10/testimonial-150x150-1.jpg. In order for it to work, I’m not sure, but that’s what I observed. Is there any way to fix it? Because every theme was working fine before and the problem started recently, even in my new account where I have only 2 plugins installed

Looking at the raw source code of the generated HTML, there is a segment of code in the middle that contains a lot of wrong HTML code.

The content contains some classes that start with uagb-, which a quick Google search tells me are part of Ultimate Addons for Gutenberg.

So my guess is that either:

  • The page content of the home page is wrong, and some content got loaded in there incorrectly.
  • The theme you’re using conflicts with the Ultimate Addons for Gutenberg plugin. Or maybe Gutenberg in general.

Looking more closely, I there are also references to Elementor in your page. I wouldn’t be surprised if trying to use Elementor and Gutenberg at the same time may also cause conflicts.

6 Likes

Thank you very much :pray:.
You are right, both Gutenberg and Elementor were having a conflict. First, I disabled Gutenberg using plugin and then installed a theme from the starter template. It was still giving me the same error because the block editor was selected in the top right corner of the starter template themes while selecting themes, instead of Elementor. When I disabled Gutenberg and selected the Elementor option while selecting themes, the issue was solved.
My bad, I thought there was a problem with hosting.
InfinityFree best free hosting ever.

1 Like