I'm getting HTTPS 500 error when I try to upload photos (Error :"No JPEG support in this PHP build")

Website URL


(please specify the URL of the site on which you are experiencing the problem)
I’m getting an Https 500 error when I try to upload files. I’m not sure why and it worked really file earlier. I tried uploading the ones I uploaded earlier as well. But I cannot upload any file now. I’m really worried as I’m running an online marketplace. Please Help! :cry:

Error Message

(please share the FULL error message you see, if applicable)

Other Information

(other information and details relevant to your question)

Please read


I just enabled the option to display errors and here’s the error I got :

It says “No JPEG support in this PHP build” :open_mouth:

Just wondering why it suddenly stopped working as it worked fine earlier and I didn’t make any changes to code either.

@Admin @KangJL Can you please help? I’m running an online marketplace and this is blocking its operations. :cry:

1 Like

It seems that the GD extension on free hosting has bugged out and stopped supporting anything except GIF.

So you must wait for it to work. Using a similar software that natively supports Imagick could also help, as Imagick is still avaliable.

Also please refrain from pinging people for help.


Sorry for asking help! I got no idea what was going on.

Will it automatically be fixed from your end? My business operations are on hold due to this issue and that’s why I’m concerned. I hope you can understand.

I was also a normal user like you and I don’t have access to the internal systems, so I cannot tell you anything about this unfortunately. And yes, I was facing the same problem.

Admin may have more info so you might want to wait for him.


It seems that there was an issue yesterday where the GD extension for PHP was missing or not configured correctly. This was likely caused by an error during a routine PHP upgrade.

I just had a look and as far as I can tell the issue was fixed. Do you still experience this problem?


@Admin Yes, I’m still getting the same error when I try to upload photos. :cry:

Here’s my website : https://classifiedy.com/

Right, I tested the issue on a few testing accounts and I couldn’t reproduce the issue there, but it seems that this issue still affects some accounts/servers. I’ll have someone look into this.

Meanwhile, I created an outage topic about it where I will share updates about this issue: PNG and JPEG support missing for GD extension on some accounts


Thanks @Admin! The issue is still reproducible and I’m losing my customers every second due to this image upload issue. :cry: I hope it will be resolved soon.

Yes, I have told this in many different topics. For further questions and updates, please check the official announcement topics.

Please don’t create additional topics about this and engage in all of them. We’re aware of the issue and are doing our best to get this resolved as soon as possible. Please don’t spam the forum: we already know the issue exists, and making more noise about it won’t speed up the fix.