I have this problem on my website, how do I fix it?

Rather than explaining the situation by writing here, I am adding a video of the problem here. How can this happen and how can I fix it?

Video:

If I understood correctly, you want “instagram” to have a glow ?

The problem is that this CSS conditions you (see my cursor and file name)
when I disable it, then it’s ok

You can also play with the order of the CSS files (the last one has the greatest power over the previous ones)

7 Likes

Actually, that’s not exactly what I meant, the problem is this:
This is what it looks like for me

This is what it looks like on my other account

and the custom css is not updated at all while doing this

On my phone, the strokes of the others are visible except the one at the top.

By another acc you actually mean another browser?
because as far as I can see the address is the same


If you don’t see the CSS changes, then clear the cache in that other browser

Please clear the browser cache by pressing a few times Ctrl + F5 while viewing your website.
If that doesn’t help (because some browsers are stubborn) then follow these instructions

on top you mean “Instagram” ?

If you look at my video, you will see that it has been overrun with Elementor CSS,
when I disable Elementor 15 CSS (text-shadow)
then (look under my cursor) how button-1 starts using your custom (inline) CSS

6 Likes

I think I didn’t explain the problem clearly. I’m sorry, my English is not very good.

The black line around the text I mentioned is sometimes visible and sometimes not. For example, I did what you said, but it is still the same, it only made the text shine.

This is what it looks like for me now: image hosted at ImgBB — ImgBB
but it looks like this on my other account: rhttps://ibb.co/rsxcQPg
and on another account like this: image hosted at ImgBB — ImgBB
(all photos from the same browser but different accounts)

This custom css {-webkit-text-stroke: 1px #000;} sometimes appears and sometimes it does not. I cleared my browser cookies as you said, but it still looks the same for me, but when I look at the video you sent, there is no problem, it works fine.

Thanks for your help in advance :slight_smile:

When I check your site now, I see a 0.1px wide text stroke, which makes it basically invisible.

Also, the CSS is included in the page, not as a separate CSS file, and the page is generated with WordPress, so no browser cache should be applied.

In the screenshots you sent, the content looks different from the page where the WordPress editor bar is visible.

Is it possible that this could be caused by caching in Elementor? It’s quite common for WordPress to show cached content to visitors who are not logged in, but show live content to people who are. That could explain the difference in what you’re seeing.

4 Likes

OK

now I understand

it is not standard and different browsers display it differently
in Firefox (my case) is white with small spots of black
while in chrome and other chromium browsers there is a black border around the letters .

I think it’s best for you to throw it out because it’s somehow prettier to me when it’s white

4 Likes

When I took this photo it was 1 pixel, not 0.1 pixel. I then changed it to 0.1px, so I’m pretty sure it wasn’t caused by me making it 0.1px.

The 1st photo is just my logged in account. The 2nd and 3rd photos are the ones without login, but they both look different from each other.

I followed all the steps here but it didn’t work.

So what is the difference between screenshots 2 and 3? We’ve established logging in makes a difference (apparently - hard to check for us). So what’s the other difference?

I just checked and see the stroke width was changed to 1px. Now it looks like a correct, thin edge. And it looks the same when I check from different browsers.

2 Likes

Do you see now? This is great but nothing has changed for me, this is what it looks like now: image hosted at ImgBB — ImgBB

I turned off my Google extensions, thinking it might be caused by my extensions, but the problem is not caused by the extensions.

I opened the site from a new Chrome account and there were no problems until I clicked on the link.

I’m sorry, but I still cannot reproduce the issue. When I check the site in a clean Chrome Guest mode profile, I see the thin black bar. If I click on the links, how they are displayed on your site does not change. If I use Inspect Element to give them the visited property, the links don’t change.

I don’t know why you see what you see. But it’s your CSS code in your WordPress site that’s causing issues for you. I don’t see anything here that could be the result of hosting behavior. So I’m not sure if there is anything we can do for you here.

6 Likes

Your browser is behaving strangely…I watch your video there after 1:00 min
and there is no difference at all when you check or uncheck the rule :roll_eyes:
It’s time to use Firefox :slight_smile:

If nothing else, at least you corrected that “instagram” that didn’t have a white glow.

5 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.