I have created my website today and have uploaded a SSL certificate


Error: demofreecourses.infinityfreeapp.com/ is not a fully qualified public domain name or public IP address.

I am actually creating a database through which I am fetching data into my flutter app. There it is showing this error
[ERROR:flutter/lib/ui/ui_dart_state.cc(186)] Unhandled Exception: HandshakeException: Handshake error in client (OS Error:
E/flutter ( 4644): CERTIFICATE_VERIFY_FAILED: unable to get local issuer certificate(handshake.cc:354))

I am assuming this error is related to the SSL certificate because I have checked it with some other Webhosting platform, and with that, it works perfectly fine.

I don’t think what you want is going to work here. Please remember that we provide website hosting, which is intended to host websites.

We do not provide database hosting (our database servers are not accessible from outside our network) and we don’t support hosting any kind of API on our hosting either.

Please remove the slash at the end. A “domain name or IP address” cannot have a slash in it. Only URLs do, but apparently the setting doesn’t want a URL.

This is probably caused by the limited SSL implementation in our system. It doesn’t work very well with any kind of automated access.

Browsers work just fine with it, which is what we’re aiming for, so it’s not really a problem.


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.