I can't access admin panel with Https

I have a problem when I enable https and cloud flare
my website and admin panel worked fine with just http
then I waited about 24 hours for cloudflare to be activated and reinstalled WordPress again with https.
The website worked but I couldn’t access admin page, it was just loading.

plus I tried accessing cloudflare from their site and set SSL to Full
now I deleted everything again and re-enabled cloudflare and waiting for it, any possible help with this issue ?

Note: I tried this many times

Now for me http://unrealdealer.com/ (which is the URL you referred to on your first topic) shows a default page. After configuring Cloudflare again and setting the SSL option to Flexible, maybe install WordPress but this time always with http:// instead of https://?

But if I install WordPress as http, I can’t figure a way to modify it to be SSL without reinstalling which means the site remains unsecure (no green locks ) even if I did enable cloudflare later.
I tried to manually change http to https from WordPress settings but it doesn’t work
plus I tried flexible and full, with no result

should I enable cloud flare in both control panel and website or just depend on one of them?
thanks for the reply!

You can just change the Website URL through the Settings → General page in the WordPress admin.

Please do note that this probably breaks if you use Flexible SSL. I’m not sure what’s currently the best way to solve this (@Ergastolator1 knows more about this than I do). But I believe that enabling “Always use HTTPS” and “Automatic HTTPS Rewrites” in Cloudflare should fix this.


OK sir, I’ll try.
Thank you!

Problem Solved!
I used SSL certificate manually by generating key and certificate using CNAME records.
then created WordPress with http and updated it to https like you said from WordPress admin.
Thank you for the help so far.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.