I can access my site, but others cannot

I have my own domain, which I added to my account on 2/1/219. In the domain control panel of my domain registrar, I pointed it to the ns1(and 2).epizy.com name servers as InfinityFree instructed me to do. After an hour or so, I was able to access my website without any problem, and I could update content using ftp. Unfortunately, other people, in other cities and countries cannot access my site. It has now been 3 days since I added it. When others try to access, they get this message:
barrybecker4.com ’s server IP address could not be found.

Could it be that there is a problem with the epizy.com nameserver?


Your website is working fine from here, but that doesn’t mean the nameservers are fully working. Our nameservers are replicated over multiple locations, which means improved performance for most of the time, but weird issues if one of these locations gets out of sync.

Do you know in which countries/cities people are having trouble reaching your website?

I am in Union City, CA.
It did not work from Soporo, Japan this morning.
It did not work from Chicago or Berkeley last night.
I will ask those remote locations to try again tonight.

your website works on my end here i’m in the us

The situation seems worse now. I cannot access my site at all at the moment. it was working for me yesterday.
Yesterday when I ran tracert, I saw:
(I replaced . with : to workaround the 2 links per post limitation)

Tracing route to barrybecker4:com []
over a maximum of 30 hops:

1 2 ms 2 ms 1 ms
2 12 ms 11 ms 9 ms
3 10 ms 12 ms 11 ms po-108-rur01.hayward:ca:sfba:comcast:net []
4 15 ms 13 ms 13 ms be-215-rar01:santaclara:ca:sfba:comcast:net []
5 13 ms 12 ms 11 ms be-299-ar01:santaclara:ca:sfba:comcast:net []
6 * * * Request timed out.
7 * 160 ms 154 ms ae-3-3.bear1:Manchesteruk2:Level3:net []
8 227 ms 218 ms 205 ms WILDCARD-UK.bear1:Manchesteruk2:Level3:net []
9 157 ms 155 ms 154 ms
10 160 ms 164 ms 158 ms cust:te3-1:cr-4.rel.ncl:wildcard:net:uk []
11 * * * Request timed out.
12 * * * Request timed out.
13 * * * Request timed out.
14 * * * Request timed out.
15 * * * Request timed out.
16 * * No resources.

Today when I try, I see only

$ tracert barrybecker4:com
Unable to resolve target system name barrybecker4:com.

I have not changed anything about the configuration.

It is still not working for me or anyone else since yesterday around noon. It was only working for me on Saturday, Sunday and Monday morning, but then it seems to have stopped. Are there any steps I can take to help diagnose and/or fix the issue? @ hamradiotv if you try it again, please clear your browser cache first.

I just noticed something very strange. It works for me from my work computer over VPN, but not if I disconnect from VPM. I guess the network traffic is routed differently when using VPN. I am in Union City, CA, but the VPN gets routed through Detroit.

VPNs pass your traffic through different servers in different world locations. These servers have other ISPs (Internet Service Providers) whose DNS services have different rates of World Wide Web DNS Record refreshing.

While one service might update its public DNS data every 20 minutes, other one might take weeks to do so.

Therefore DNS Propagation is caused by the DNS Service providers theirselves and their ISPs.

As far as I know you can change your default DNS Service provider to an one that has a better refresh/speed/quality.

A tutorial on how to change your device’s DNS Server

List of publicly known, free DNS Servers.

In the best case, that would only fix the problem for me right? Not everyone else who is also having trouble accessing it. Anyway, I will give it a try later to today.

Every DNS Server refreshes their public records after a certain period of time.

Judging by the number of people reporting DNS issues, it’s likely that at least something must be going on with the nameservers. I’ve asked iFastNet to investigate.

It seems to be working again for me at the moment. My friend in Japan can also now access it for the first time (after 4 days). Hopefully it will continue to work going forward.

My site is down again. Did iFastNet discover the problem?

It is working again, but who knows for how long.

Yes, it’s a faulty DNS server. It’s being removed right now.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.