"?i=1" interfering with my webapp

epiz_27132979 https://icecoder.epizy.com/ICEcoder%208.0/


my web app that was forked from https://icecoder.net/, whenever I load it, the URL parameter ?i=1
causes it to create the CSRF issue, I’m 100% confident this is the issue cause whenever I remove the parameter, it fixes the issue

so I’m developing a Web Hosted Programming Platform, and I initialize it and I get this error
PHP error:

Bad CSRF token. Please report the error info at https://github.com/icecoder/ICEcoder so it can be fixed.

CSRF issue:
SESSION: 4aa0410b8b12c8732ba1e9e686b93783
FILE: /ICEcoder 8.0/lib/settings.php
GET: array ( 'i' => '1', )
POST: array ( )

I did some trial and error and this is due to your required parameter ?i=1, is there a way to disable this? as my web app cannot function properly as long as it is enabled.
if you need to recreate the error go here

You can use custom domain and CloudFlare


i can’t at the moment. have no way of doing so

i’mma just say i do not want to buy a domain right now

@FlutterHoney thank you tho’

@FlutterHoney, do you have a method that doesn’t involve purchasing a custom domain, (i plan to transfer to one in the future) i have a small team that is helping me and they need accounts but when i try to enable multi-user (allows additional registrations) it causes the error mentioned above, and i can’t fix that by editing the url (my little workaround was to delete the parameter in the address bar, but it doesn’t work for this case since it’s not a tab) i trust that u know your stuff from your profile. lemme know if you have any solutions.

@FlutterHoney oh and, i tend to have this problem (this is why stackoverflow always closes my topics) where my posts are too broad or not clear enough? would you mind guiding me through the process of making better questions and topics?

@foxygames Use freenom.com

1 Like

@OrangeKale64 thank you but i’m looking for solutions that don’t involve switching providers, I want to be able to do this with resources what I have.

You can still use infinityfree’s hosting, freenom is only for a domain so you can use cloudflare so you can disable the security check that adds the ?i=1


@OrangeKale64 oh, ok, i’ll definitely try this

1 Like

Just don’t use .tk extension. Use .ml,.ga,.gq,.cf etc



@anon2458064, would you mind explaining this to me as I am relatively new to programming although I’ve been doing it for a while now, I’m still learning this stuff.

@Deveroonie @OrangeKale64 I am on a school computer right now (Chromebook) so I can’t access frenom.com, I will try it when I get a chance. sounds promising. In the meantime, do you have any solutions or workarounds that can be done without a custom domain?

@OrangeKale64 this is free right? (I’m assuming by the
“free” in freedom)


But only for the first year, then u need to renew or get the same domain with a different extension (NOT TK COS IT IS BANNED HERE)

1 Like

Step one : freenom.com
Step 2 : put in the domain you want not .tk but anything else
Step 3. Add it to cart.
Step 4- Sign Up
5. Checkout (THIS IS FREE)
and you’ll have your domain.
There are many tutorials on youtube. just follow any tutorials

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.