HTTP to HTTPS (And redirection to other website)

Redirection works great but how I make it secure?

I have already tried the .htaccess thing, it works perfectly, if i put https it shows up as secure for redirection, that’s perfect but the problem is that it appears as not secure if I don’t add that.

I would like it to be secure without having to put that, for example “” without having to add “https”

I have it forced to HTTPS but what I want is to redirect the domain to another website. The problem is that it appears as not secure, since for it to be forced it seems that it would have to continue loading the page but what I want is to redirect and I don’t like that it appears that it is not secure if I don’t add the “https”

I see in the Source Url that it is listed as http. Isn’t there a way to change it to https?

I would greatly appreciate your help.

Is SSL cert installed on the other website? If so, edit the .htaccess of the other website to enforce strict SSL access only


Yes, I want to redirect to TikTok website.
Problem is with my site.

What should I do?

What problem?

No idea. You need to write clearly so that we can help you.


Can you share the code you are using for the redirection?


My domain is
I uploaded the .htaccess thing to force HTTPS. What happens is that if I put HTTP I see that appears as not secure. I know, makes sense, but why is not forced in this case? It’s because is not loaded? For example, if I don’t redirect and I continue on my site it will appear as secure but for redirection no. While redirecting it appears for a while that it is not secure.

You may think that doesn’t matter, but I don’t want people who visit my site to be scared because they see that. Maybe next time when they refresh the redirection will appear as secure , but I want it to always be secure, even the first time they visit the site. For example, if I visit the website in incognito it always appears as not secure until is redirected to the other one.

I’m just using this for redirection.

Is there a way to make it start with HTTPS instead of HTTP?

If I do it from there, it always starts with HTTP and shows up as not secure.

Could you help me please?

Because you did not use HTTPS


If I type https:// or http:// for your URL, I get redirect to TikTok either way.

Try clearing your cache:


I know, but I can’t change that?

I want it to be https for redirection, not HTTP

I just don’t see any option to change that.

Any other way to redirect? That’s always starting with HTTP

What do you want to change? The redirect works fine over both HTTP and HTTPS



1 Like

I already said, it appears as not secure for new people visiting it. I don’t like that.

I think you are not even reading what I’m saying.

I already mentioned that above.

Not true, appeared as https to me


1 Like

That’s TikTok, not my site.

Can you share the .htaccess file?


Solve it yourself. We are not obliged to help you since you cannot even write properly


That’s why I’m asking for help. I already explained everything above.