HTTP 500 Error after i did something



500 HTT-P Error

This page isn’t working

playringforum is currently unable to handle this request.


Other Information

Hello i just did my SSL certificate and it was working with but when i open my website was opening it without the SSL What i did to break my website is i tried to make a redirect from ttp to ttps true the control panel and then this error started to appear … Please help me!

1 Like

I dont quite undurstand what do you mean, everything was working fine untill i installed the SSL and tried to redirect http to https with the redirection providet in the control panel, then i deleted the redirect but i get the same all over again and again i dont know what to do … i tried to enable errorr to show but nothing happens …

Can you please explain more? You have not enabled display errors yet.

Already explaned.
First i did the SSL Certificate true Zerossl, then i when in control panel / SSL / TSL i uploaded my SSL certificate there and it was working perfectly. However i was opening the website with http and it was not opening it automatically with the SSL Certificate with https it was working fine. Then i went into control panel > Domains > Redirects and i tried to redirect the website with htt-p to http-s . Then it breaked and started to show this error, i checked the forum for a solution and i went to Alter PHP and i set the Display Errors to On so i can see if there is any problem, however it does not show any erros even when is turned on. Then i removed the Redirects from Domains to check maybe everything will go back to normal but it didnt. It still stays broken.

Delete the redirect and follow this guide: How to force all traffic to HTTPS - Docs - InfinityFree Forum.

Most likely your .htaccess has an error in it. Follow Yellow_Pikachu’s advice and go to this page:

As often as you have to change code when you copy/paste it from something, the example provided is able to be copy/pasted directly into your .htaccess (at least from what I have experienced) as is with no modifications.

1 Like

Put this in end of your htaccess file (which is inside htdocs)

php_flag display_errors on

Remember without knowing the error and the reason for your issue, you cannot guess what causes your issue, Nor can we.


If the htaccess is corrupted or is the one giving the error it won’t work though.

1 Like

No, actually if htaccess is corrupted then it will redirect to

Oh, hmm.

Makes sense.

Isn’t it defined in the main .htaccess?

1 Like

I see that display_errors is enabled in your .htaccess. But ultimately, it can also be overwritten in PHP code. So if your PHP code specifically alters how errors are handled, the hosting settings won’t work anymore.

And a quick look through the init.php tells me that that IPS indeed overwrites default PHP error handling with their own system. They seem to have their own error logger, but I can’t figure our how that works.

I also found something else: a function checkLicenseKey which had an empty body.

Can you please confirm that you have a valid license for this software? IPS is expensive software, it’s not common to see people spend so much on software and nothing at all on hosting.

It is not from the software and i also just bought a hosting in ifast and also asked how can i migrate my forum there.
As i explained something happened when i was adding the ssl, is it possible that i used my domain when i was buying the ifast host ? I did not changed any nameservers or e.t.c.

Now as i started to think this happened exactly when my service at Ifast was activated, the forum started to give this 500 error :smiley:

Just ask iFastNet to migrate the site for you. They have scripts to automate the whole thing.

Your domain name is currently pointing to an iFastNet premium hosting IP. So it appears your entire site has been migrated already.

That also means that we can’t really help you here. Nobody here but you has access to your premium account, and premium hosting works quite differently from free hosting.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.