How to point my domain using coudflare to infinityfree host

Please help, just a newbie to web deployment.
First of all, I am using domain.com as my domain provider and infinityFree for my hosting. Everything was working smoothly from changing my DNS nameservers to infinity’s nameservers and my site was totally fine at first until I just recently encountered configuring my SSL (self signed certificate) in my control panel then everthing went difficult for me. Given that Self Signed Certificate is not removable and my site became forbidden to access because it was forcing my site to use Https. So that’s when I started using Cloudflare for free SSL Certificate and what I did is I changed again my DNS nameservers (from domain.com) to Cloudflare nameservers and deleted infinity nameservers as the previously registered. After that, I registered the infinityFree nameservers into my CloudFlare DNS Records as showed in image below…

Did I done it wrong? my site is still not working

You must use A Record for pointing your domain to your hosting via Cloudflare.
How to find your hosting IP for A Record: Docs - InfinityFree Forum

5 Likes

Hi, thank u. Just tried adding A record pointed to my hosting IP but my site still not accessible. does it takes time to read changes in cloudflare ?

In the Control Panel you can enable Cloudflare

It takes a bit of time(DnS propagation)

1 Like

But it will ruin everything, best thing to do is registering cloudflare manually then adding your domain through CF dashboard.

3 Likes

It also helps us to add various kinds of dns records

I tried but unfortunately I get this error for I already activated it in my other accout.

please read what i wrote:

Hi, I am already registered and added my domain.

Then no problem

And followed this instruction - Docs - InfinityFree Forum. I pointed my domain to my hosting IP using A Record via CloudFlare. Now I am currently experiencing this… as shown in the image below

Are u using wordpress?

Yes

4 Likes

Step 5 is confusing:

Double click the value in the option_value column, and change the start of the URL from https:// to http:// .

it is already http by default.

Hey listen.
Disable Cloudflare first.
Point the nameservers back to epizy ones.
Now clear cache, site data, cookies etc everything.
Your website starts working fine again.
Now log into wordpress,
Go to Add new plugin: http://domain.name/wp-admin/plugin-install.php
And Search for “Cloudflare Flexible SSL” plugin by One Dollar.

Now activate it and wait for few minutes
and then enable cloudflare again as you did earlier from dash.cloudflare.com not cpanel.epizy.com

@AgustD I hope this will solve your question.

Reverting it back to where it was working is nice idea though, but it will just force my site again going to https, back to forbidden access again. How could I prevent that? I really regret that I’ve configured the Self Signed Certificate (sigh) and now it doesn’t want to be removed so I just leave it empty.

No no, for that generate a SSL using LE offered by InfinityFree?
That will work for sure.

Yes it was from infinityfree. Okay will do your suggestion. Thank you

1 Like