Hotjar Plugin

i am trying to install a plugin. but when i click on install now it shows this error.
Installation failed: Download failed. cURL error 77:

Is that really all that’s shown? Because the colon at the end implies that an actual error message should follow.

Also, what kind of plugin is this? Is this a WordPress plugin, or a plugin for some other website software?

Next time, be sure to fill in the topic template. It may seem a bit pointless to have to answer all those questions, but they really help us to get started with fixing the issue right away, rather than having to go back and forth just to figure out what the issue is.

1 Like

yes that is what is shows and it is a Wordpress plugin. but i fixed it by downloading the plugin and upload it.

nope it is not fixed. i tried updating a wordpress plugin but it said Update Failed: Download failed. cURL error 77: the plugin was called DMCA Website Protection Badge

Hmm, that could be a server issue. But to figure that out, it would help a lot to know which server the issue is on. What is the domain name or URL on which you’re having this issue?


it is

I checked the cURL setup on your account with a basic testing script, and I wasn’t able to reproduce any issues with SSL connections to the WordPress plugin system or any other SSL issues.

Are you sure the messages you shared are actually the full error message? In the web results I found, there was always another message after the colon, which actually varied depending on what the issue was. Do you really see just the “cURL error 77:” ending with a colon and no message after that? Because if there is more, please do share it.

Nor did I expect it would. We’re still in the “figuring out what the issue actually is” phase, not “attempting to fix the issue” phase.


again this is what i see


now i am now trying to install yoast seo wordpress plugin unto and it shows that error.

any ideas @Admin?

If you still have that “cURL Error 77:” Error, try installing the plugins you want to install through FTP. Here are the instructions: Manage Plugins – Documentation –


wait do i delete the previous elementor plugin. when i delete it. it says are you sure you want to delete all of its data, but i don’t want to delete any data.

any ideas?

idk if this helps


No idea here. An ambiguous status code (77, which can mean different things) with no additional information, which apparently only shows up on a single website, doesn’t make it very easy to diagnose any issues.


so what should i do now? @Admin

can someone please help me

I’m at a loss. With only a very vague and ambiguous error message which I cannot reproduce on your account or on other WordPress instances, I don’t really have anything to go on.

1 Like

so what do i do now?