Hosting creating issues in circle

Basically, I am going into a circle for a long time. I get a database issue " Error establishing a database connection" and then I resolve it and forget how I did it as I try multiple solutions. Then I get 500 internal server issue. I resolve it. Then I get another issue. I am just going into a loop of these problems and I cant figure out why these problems exist even tho it was a clean upload of a backup.

Also as we are at it, could you see why cloudflare ssl https is causing issues. I have created a cloudflare account and added the website. Enabled it in control panel still not working. I used to get an issue of showing directory but thats resolved now.
The website is below.

Welcome to the worlds of software development and systems engineering, where some days are just playing whack-a-mole with bugs and other issues.

As for SSL/Cloudflare, your domain is not using anything related to Cloudflare right now (neither our control panel integration), so that’s why you don’t have Cloudflare SSL now.

As for the database connection error, that’s a quite meaningless error from WordPress. If you want to get the real error message, you can enable debug mode in WordPress: Debugging in WordPress – Documentation

After that, you can compare the displayed error message against this article to find an explanation for the underlying error:

1 Like

Thanks a lot. I really appreciate your legendary response however, I still have the issue. Its the "Access denied for user ‘epiz_123456789’ (using password: YES) " error. I have checked and copied the database name, hostname and password but the issue still persists.

You might want to try typing each character individually. Copy and pasting can sometimes lead to there being an invisible character there that you can’t see. Also make sure you’re using the hosting account password, not your client area password.


@Dog2puppy1 thanks a lot for your response. Yes I tried that too tho I will do it again. With hosting account password you mean the password where we click on all accounts, then the account we are talking about and then you see the password on ’ Account Details- Basic information about your account’?

I will admit that it took me way too long to notice, but the issue was with the database hostname. You configured your website to use sql207, but your account is assigned to sql107.


You’re great admin. You are one legend.
I am not sure what you did tho. The website is all new saying congrats now you can start creating your website although I have uploaded everything under the right folder.

I tried deleting the index.html2 file and fresh install. I have also gone through the forum suggestions, but I still go on to the normal fresh page. Everything is in htdoc folder

Admin are you there?

admin isn’t always active. please be patience :)

1 Like

I don’t see the default page on your website. Did you try to clear your browser cache?

1 Like

thanks for replying. Ive been waiting for a response. when you go on the website you see a brand new page with nothing useful in it. The site has already been developed so when you go on the link, you should see a full website with menu and links etc. I cant seem to load my website but instead a brand new wordpress page comes up


When I visit, I see a partially loaded WordPress page. It can’t fully load because the site itself is configured to run on a different domain. You should be able to fix this through the WordPress admin or the database.

1 Like

@admin thanks for your response. Do you have any timings when you work so I know next time. Its like one response per day which is delaying everything. Obviously, because I do not know when you work or I dont get the notifications which I need to sort out.

Anyways, I do not understand what you mean tbh. I have activated all the plugins as they were deactivated themselves. I have tried debug mode, memory increasing but nothing seem to work. I have tried other domains etc. I do not know what to know in my WordPress admin panel or database. Are you sure right database is being used now?


Not really. I’m here whenever I have time to be here. Usually that’s in the evening but it varies. Premium hosting has 24/7 staff available to help you, I can’t offer that myself.

This is what I see when I try to visit your website:

What you can see here is that it does load in a WordPress page, but that the page appears to be configured for, which is why all the styling is missing. This likely means that the website is configured for that domain instead of

Changing the URL of a WordPress site is done like so: Changing The Site URL – Documentation –

I know it’s using a WordPress database, but I didn’t check which database that is or whether that database is the “right” database.

1 Like

Thanks for the help. I do not think that is causing the issue. I have tried all the domains used for the site. The domain you mentioned to which my site has been configured, does not load the website correctly either. The website only loads a brand new wordpress installation and shows the new fresh page rather than my theme and content. I have tried the suggestion you gave me but that did not presumably work. I really appreciate your help


I see you have update the website URL for, but it’s a different URL now:

The WordPress installation on also refers to

Each website should have it’s own database which are each configured to use the domain you’re trying to show the website on.

1 Like

@admin, the only reason I used as an aliases domain so we do not mention other domains here coz i dont want my website to be available on the forum lol. Would you please remove the other links in the forum if u dont mind?
The website was initially created on 4…couk domain but then once moved to u, I added other domains as Aliases. I tried 4…couk website on your host once u resolved the database issue however, it did not work. None of the domains work at all so if its the database issue then not the right dtabase is being used. I thought the correct database was the one I was using not the one u figured out to be the right one


@admin, i see the website loads but nothing of my content, theme etc loads at all. Basically, its like a brand new website which loads

The symptoms I described in my previous post still appear to be true: both of your .ga websites are configured to use the domain. If you followed the instructions from the WordPress article I linked to before, that probably means that some of your sites are not using the “right” database.

As to which database is the “right” database for which site, I don’t know. I didn’t create or populate the databases, so you can probably make a better guess about that than I can.

If you make sure that every website has it’s own database, and that this database contains the website URL of the website that is using the database, all your sites should work.

1 Like