Help with htaccess file

Hi again!

I’m in my epic battle to get my subdomain to run with SSL and I’m making some progress.

In my subdomain I am running IPS IC 4.4.10 and managed to make the Cloudflare certificate work, however, it appears that the site is not full secure in some places, the error message that returns is as follows:

“[Your connection to this site is not fully secure]( Attackers might be able to see the images you’re looking at on this site and trick you by modifying them.”

Ok, that’s 'cause I didn’t change the conf_global.php file to run over https, so, I did this, and then I receive the following error:


So I thought it might be a problem with the httacces file and made some modifications to it, but I confess that I am guilty of not really understanding how it works, then, I receive the following error now:

500 Error, please check your php script / enable display_errors in your cpanel

I would not like to expose my domain here, so consider the domain you want. I just need to configure my htacces correctly and I will be very grateful to anyone who can help me make the necessary modifications to it.

My htaccess file:

<IfModule mod_rewrite.c>
Options -MultiViews
RewriteEngine On
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule \.(js|css|jpeg|jpg|gif|png|ico)(\?|$) forum\.mydomain\.com\404error.php [L,NC]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . forum\.mydomain\.com\index.php [L]

Too many redirects error might be caused if you enabled strict ssl from cloudflare (forcing http redirects to https)

500 error might be solved by changing your php version

Regarding .htaccess i don’t really have idea about it

Please note that Flexible SSL works by having a HTTPS connection from your visitors to Cloudflare but an unsafe connection from Cloudflare to your account. This means that our hosting server receives an unsecure connection, even if your visitor is using HTTPS.

Some website software, when configured to use HTTPS, checks whether the server received a secure connection. If it didn’t, then the visitor will be redirected to HTTPS.

But when using Cloudflare’s Flexible SSL, this redirect still happens, but the visitor is already using HTTPS, so IPS will keep redirecting people to HTTPS even when they are already using HTTPS. Hence the redirect loop issue.

To fix this, IPS must be configured to not look at this connection information as the sole source of truth. Maybe IPS has a Cloudflare option, maybe there is a “Load Balancer” or “Trusted Proxies” option or plugin instead. I don’t know IPS well enough to tell you exactly how to do that.

Alternatively, you can switch Cloudflare to Full SSL mode, but that requires the installation of a valid SSL certificate on your hosting account. You can use our free SSL certificates for this.

But I am quite sure that this can’t be solved with .htaccess rules, and that the “500 Error” message is probably generated by invalid .htaccess rules on your site. So I would recommend to revert the changes you made to it and try something else.

Also, not to accuse you of anything, but I would like to remind you that using cracked software on our hosting is not allowed. IPS is a $175+ per year package which you’re hosting on free hosting. That’s suspicious.

If you want to create a forum for free, there are plenty of free forum scripts available. If you really want IPS, you need to pay for it.


thanks for the help, I’ll try it just for knowledge.

About the licenses, shame on me… I’m just a poor guy of a poor country, full of dreams and empty of money. I`ll provide another Bulletin Board, with a free license, for my site. Thanks again and sorry for breaking the rules, I was not aware of that.

In the future, if my site is successful, I will purchase a license for IPS, 'cus this is my favorite bulletin board, and I will hire Infinity’s paid hosting service as well, as the service has been essential to me at the time and I wish I could repay it!

Thanks again, see ya!

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.