Help: 404 Error after adding domain to Cloudflare account

schoolpsychologistscouch.com
schoolpsychologistscouch.com/wp-admin/

Error: 404 page not found

Everything was working fine when it was set up and just http. Once I routed my domain through my cloudflare account, i can no longer access the site or the wp admin dashboard. Please help.

do you have the correct dns settings for your website?

I have utilized the DNS settings given by CloudFlare

Inside Cloudflare, In the DNS section, does the A record match the IP address in the client area?

1 Like

I wasn’t able to find the assigned IP address but after using Google’s Dig tool the IP address returned does not match the one in Cloudflare.

Google Dig A: 185.27.134.138
Cloudflare A: 162.255.118.194

How do I fix that?

Your site http://schoolpsychologistscouch.com/
throwing this Error:- ERR_TOO_MANY_REDIRECTS, first solve this error.

We(anyone on earth) can’t help unless you provide a screenshot of your dns records in https://dash.cloudflare.com

6 Likes

:+1:

1 Like

Were you able to solve this issue? The Problem is in the above screenshot there is no A records assigned. To resolve
Step 1. pls remove the site from cloudflare
Step 2. Go to your domain registrar eg. GoDaddy, Namcheap etc.
Step 3. change your nameservers to InfinityFree Nameservers ie: ns1.epizy.com and ns2.epizy.com
Step 4. Add the site back to cloudflare by clicking on add new site doing the things that cloudflare asks you to do. ie change nameservers.

AND Please turn off redirect to HTTPS in Cloudflare because that sometimes causes to redirect many times and cause an error as quoted by @Amaanwarsi below

4 Likes

That’s a Namecheap IP. Any idea why there’s a Namecheap IP on your domain?

If you want to host your website here, you should have DNS records at Cloudflare which point to the IP address of your hosting with us.

Here is a bit more information about this:

3 Likes

you can find your dns settings in the main account page

The one without /wp-admin and it works for me.

Clear the cache and try again

use 185.27.134.138 as the dns setting on cloudlfare

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.