Gzip Compression HTML


Gzip is not working properly:

Your server may not have the “deflate” module enabled (mod_deflate for Apache, ngx_http_gzip_module for NGINX). Contact your host. If deflate is enabled, ask why all .htaccess or nginx.conf compression rules are not being applied. If re-checking and restarting does not resolve, please check with your host.

I’m trying to enable Gzip compression on my site for HTML, Javascript, and CSS.

It is show me the above message. can anyone please help me?

Our servers enforce GZIP compression by default. But to my knowledge, the decompression is done in NGINX, for which you can’t access the configuration directly. You can control some Apache parameters through .htaccess, but either you can’t edit compression settings there or compression isn’t done through Apache in the first place.

Regardless of how compression is being done, the answer to your question is the same:

We enforce compression by default and you don’t get to change those settings.


Ok sir

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.