Full Support for GRAV CMS


Recently I discovered GRAV, a flat-file CMS and fascinated by its versatility.
It’s a fairly lightweight flat-file CMS with easy installation and highly modular in nature.

Most of it’s feature modules can be added/removed via FTP but their (GRAV team/developers) preferred method is by using the included package manager called GPM which do not work on InfinityFree Platform.

Also, when installed via softaculous, the built in installers/updater fails

Wish the InfinityFree team may look into this and provide explanation, if not solution to this.


We don’t provide SSH or other command line access on free hosting. This means that using Composer, Artisan, WP-CLI, GPM and any other command line application in PHP or any other programming language cannot be executed on our hosting.

The same is true actually for iFastNet’s premium hosting. Only their Business Hosting and VPS plans come with SSH access, which you need to run commands effectively.

I’ve never used this CMS before, so I don’t know how these installers work (or don’t work, in this case).

When you’re referring to Softaculous, does that mean it does work on a manually installed copy of GRAV? Or did you try it on only one installation which just so happens to be created through Softaculous.


I’ve tried both and found the same problem
Grav installed via Softaculous or Grav installed via FTP/PhP setup showed same error

In that case, I don’t know. It could be a GRAV bug or something else. I don’t know the CMS myself well enough to tell.



Have you tried to upload a theme file/plugin file on your site via FTP?
Try uploading the theme/plugin file which is a .zip file and unzip it in …/user/plugins/ or …/user/themes.

Once you are done putting them on the right folder, Sign in to your Grav Admin Dashboard and then go to Themes, or Plugins and then find the Theme/Plugin that you would like to activate and then press the Activate button.

Hope this helps!

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.