FTP Problem

Dear Sir,

I am trying to delete an image from the ftp. It shows that I deleted using winscip and net2ftp.com.
However, if any one is trying to access it using my website link suppose we can say www.webcodingarea.com/images/photo.png

This photo.png is deleted and is shown like that on all FTP softwares but if I need to access it using the browser it is still shown.

I tried to clear the cashe from my network and still the same problem.

Is their a way to clear the cache from the CPANEL?


We do apply some caching but if a file has been deleted it should be removed from your website soon as well. How long ago did you delete the file?

About more than 24 hours. Is the problem because of cloudflare ?
I moved the nameservers of cloudflares and not enabling it through the CPANEL !!

If you’re using Cloudflare, it’s very likely the image is being served from their cache.

To test your theory, you could try to purge the file in Cloudflare’s cache. To do that, login to Cloudflare, go to Caching and click Purge Individual Files. Enter the URL to the image there and click purge. Then wait a minute and try again.

Hello Admin,

I need to thank you for your kindness and your support. I have another question: I uploaded a file inthe FTP and it can be read using the winscip and Net2ftp softwares. However, when I am trying to access it a 404 page displayed by infinityfree.
Is the problem also fron the cloudflare ? Shall I clear the cache with the given steps from the cloudflare ?


You could certainly try to clear the cache in Cloudflare, but as far as I know Cloudflare does not cache 404 errors. It’s more likely I think that you simply entered the URL correctly.

A common mistake is that a website is tested on a Windows system and works fine there but doesn’t work on our Linux servers. That’s because file names in Windows are not case sensitive but on Linux they are, so if you upload a file called FileName.JPG on a Windows system, you can access it as filename.jpg, but that won’t work on Linux.