FTP failing

Username - epiz_32831297

Website - bd-travel.infinityfreeapp.com

Status: Resolving address of ftpupload.net
Status: Connecting to…
Status: Connection attempt failed with ETIMEDOUT - Connection attempt timed out.
Error: Could not connect to server

I use FileZilla for FTP and all was working ok until yesterday. I have tried a different computer and I still can’t connect.
Using Host - ftpupload.net
Username - epiz_32831297
My cpanel password
Port 21

Any ideas? Thank You!



I have tried logging into control panel - that works.

I have checked and double checked credentials. I have used several computers connected to my Spectrum router - they all don’t FTP the same.

I have changed my password, rebooted computer - FTP still doesn’t work.

I don’t see anyway to check ALG settings in the Spectrum app that accesses the router. I reset router to factory settings - FTP still not working.

I’ve used ftpupload.net and ftp.epizy.com and they both resolve to the same IP, Still not connecting to server error.

I don’t know how to use VPN to connect FileZilla so that is not an option.

I am out of ideas!
Thanks though.

  1. Install a VPN
  2. Connect to FileZilla while connected to the VPN

Try using a different computer, and/or a different network

Try visiting a library or public coffee shop (Make sure you are connecting securely if so)


Thank you Greenreader9. I have installed Proton free VPN and tried FileZilla, no help.

I have also tried two different computers. I will ask a friend to try same login from their computer.

What bothers me the most is that when I setup the account ( a week ago), I used FileZilla on this computer and it was working fine. It just stopped a couple of days ago.

Never mind! I just realized I had not started the VPN. When I did, it worked. Wonder why it worked before without VPN?


So the issue is probably going to be a policy on your router, possibly by your ISP.


Thank you Greenreader9! :grinning:

Just talked to Spectrum and they had added a new “security” feature which blocked my FTP attempts! Don’t you just love it! :rage:


Glad you figured it out! We’re they willing to remove the block for you?


Yes they did unblock and it is working again! All is good.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.