FTP Connection Problems

Hello, when i am trying to connect to ftpupload.net via filezilla, using my username epiz_25408466, i get error “ECONNREFUSED - Connection refused by server”.
Also ftp is not down, everything works in browser and file manager.

Try to connect to with your hosting account credentials and see if it works?


I tried already, it gives error anyways


As you can see @Admin has already pinned this topic on the forum discussion.
Please refer to it.

There are some issues with the FTP service right now, but ECONNREFUSED is not a known symptom.

Could you please check if you can connect over a VPN to rule out any network blocks on your end?

If that doesn’t solve the issue, then could you please share more debug logging from FileZIlla?


EDIT Never mind, I was just doing a bulk transfer myself and I’m getting the same error too after the server kicked me out after hitting the user limit. So it’s probably related.


Okay but anyways, logs:
Status: Failed to establish connection with “ECONNREFUSED - Connection refused by server”.
Error: Unable to connect to server

But also if I connect without entering an ip address to ftpupload.net, filezilla gives another error
Status: IP Address Definition for ftpupload.net
Status: Connecting to …
Error: Connection terminated after 20 seconds of inactivity
Error: Unable to connect to server

In all cases, just unable to connect to the server

The FTP server went down briefly around the time you posted that. Could you please check again now?


Yes, i checked and it shows ECONNREFUSED again, maybe i am in blacklist or something like? Because when i tried from another client on my phone, no error was displayed and i could to connect.

We don’t blacklist any IP addresses, unless maybe you’re getting rate limited? But those blocks shouldn’t last long. Was the phone on the same network on the primary device or was it on a different network?

Yes, phone was on the same network, i tried to connect again from phone and it works.

There is no way for us to really distinguish devices in the same network (assuming they are behind the same NAT IP), so I can’t think of anything on the server side which could explain this. The most likely option as far as I can tell is something on our primary device blocking the FTP connection, like a firewall or virus scanner.


I found some information about this on the filezill website, I need to have the same IP address as my computer or something like that, it was said here ECONNREFUSED - Connection refused by server - FileZilla Forums

and I think this is the solution to this problem, a person under the pseudonym Morgal wrote on the forum filezilla: "
I have now fixed the problem.

It was to do with windows firewall.

Even with the Filezilla executable listed in the exceptions list, it is still being blocked somehow. Turning off the firewall completely “fixes” the problem.

So its just a case of finding out what the difference is between what used to work, and what works now.

", I haven’t tried changing the firewall settings before.
I will try and tell you everything.

Edit: Yes, that helped me, thank you all for given help

1 Like

New problem…
When i try to login it gives error
“Login authetification failed”
This might be problem not only for me, because ftpupload.net is down or something like that

It might be a problem which is not just for you. But so far, you’re the only one I’ve seen who has this issue. So either everyone else who has this issue is not saying it, or it really just is you.

Did you try the instructions from this article already?


1 Like

Oh, my account got suspended and i cannot access ftp because of it.:roll_eyes:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.