FTP connection always times out now, after failed connection attempts

Username: epiz_26156525
Web Site: Malaika’s World

I have used FTP for years with InfinityFree, and it has always worked without issues. Today I was trying to set up my text editor to automatically upload files over FTP after I edit them. While testing this out, I had an issue with entering my password, and ended up failing to login a bunch of times. Immediately after these failed attempts, all connections to ftpupload.net now receive a “Connection timed out”. I have tried in various FTP clients (FileZilla Windows, ftp and vim on Linux) and it’s the same in all of them, it times out before connecting to the FTP server.

Things I’ve tried:

  • Logging out of InfinityFree and logging back in
  • Loading the Control Panel for the web site in question
  • Resetting the password for the FTP account
  • Confirmed ftpupload.net is resolving to the correct IP address:
  • Confirmed a traceroute gets all the way to the IP address without any timeouts along the way

The problem appears to be on InfinityFree’s end, as it never actually connects to the FTP server. The connection is being dropped/ignored, and my client eventually calls a timeout error. It worked fine multiple times earlier today, until I made a bunch of failed username and password attempts in a short period of time.

Thank you.


I have confirmed that I am being blocked by InfinityFree (or else the infrastructure provider).

When I connect with a VPN, it connects without issue. So it seems my IP has been blocked/banned from the FTP server. How can I get it unbanned?

I have been unblocked from the FTP server. It was probably a temporary ban for 2 hours or something like that. I no longer need help.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.