FTP client login fails

Website URL

(please specify the URL of the site on which you are experiencing the problem)
The received Error is
‘Connection timed out after 20 seconds of inactivity
Could not connect to server’
(please share the FULL error message you see, if applicable)
I moved my website to to Infinity Free about a year and a half ago and have left it until now when I wish to do some work on it. I made notes at the time of what I thought were the necessary login details for my FTP client. Since then the computer I was using died so I am starting with a different machine and have been trying to connect using Filezilla and WinSCP. I have no real experience of using an FTP uploader so I assume I am just entering the wrong login data. Let me run it past you:
For Host I am entering ‘infinityfree.com
For Username: I am entering my Account Details username beginning with epiz_ followed by 8 digits.
For Password: I am entering my Account Details password which is a mixture of 10 alpha and numeric characters
For Port: I am entering 21.

I think that at least one of these items of data must be wrong. Can you guide me, please.

(other information and details relevant to your question)

It’s ftpupload.net :wink:


Hello Hosting Support,

The URL that the connection is failing on is…

The full error message is :

Status: Connecting to…
Error: Connection timed out after 20 seconds of inactivity
Error: Could not connect to server

I have tried connecting to ftpupload.net as suggested by ZippyCandy. It connects to a server but gives me the error below:

Status: Resolving address of ftpupload.net
Status: Connecting to…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Error: Remote certificate not trusted.
Error: Critical error: Could not connect to server

That’s because you’re using the FTP hostname infinityfree.com. But there is no FTP server on that IP address at all, so of course you won’t be able to connect to it. The IP address you’re seeing is the IP address from Cloudflare on which our website is served.

That’s actually the correct IP address, which means that ftpupload.net is the hostname to use.

The error “Remote certificate not trusted.” is interesting.

Normally, when you first try to connect to an FTP server, FileZilla will prompt you with information regarding the SSL configuration of the FTP server. When you use ftpupload.net, you should see a valid, trusted certificate that’s signed for ftpupload.net. But you’ll still need to approve/trust this certificate manually. When you click trust, you should be able to connect securely without having to approve the connection again.

If you get the error “Remote certificate is not trusted”, I’m guessing that you rejected the SSL certificate that was presented.

Do you see a popup with SSL information if you try to connect again? You should be presented with a certificate that’s valid for ftupload.net and is issued by Sectigo? If you see it, please click the button to trust the certificate and you should be able to connect.


Hello Admin,

I have accepted the certificate as you have suggested but now get another error message as below:

Status: Resolving address of ftpupload.net
Status: Connecting to…
Status: Connection established, waiting for welcome message…
Status: Initializing TLS…
Status: TLS connection established.
Status: Logged in
Status: Retrieving directory listing…
Command: PWD
Response: 257 / is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (185,27,134,11,92,202)
Command: MLSD
Response: 150 Accepted data connection
Error: GnuTLS error -110 in gnutls_record_recv: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error: Could not read from socket: ECONNABORTED - Connection aborted
Error: Disconnected from server
Error: Failed to retrieve directory listing
Status: Disconnected from server

That output seems normal to me. What do you see besides this? Do you see files and directories appear in the panel on the right?

It looks like the connection was established successfully. The “GnuTLS error -110” is normal, and is usually the result of the connection being closed by the server for inactivity. Our FTP server closes idle connections quite aggressively, but this shouldn’t affect your ability to use the FTP server.


Hello admin,

I have been using tried your last suggestion using FileZilla and have confirmed the errors I have reported above. However, I have just tried again using WinSCP and have successfully logged in and have been able to download my website to my desktop machine. It seems that the last error I reported points to an issue with FileZilla and which does not affect the operation of WinSCP. So many thanks to you, to Hosting Support and to ZippCandy for all your helpful suggestions.



Hello, the problem I think you are concern about is:

However, it is important to note that it is not any critical errors.

The FTP Server closes the connection when you have idled (not uploading/downloading files) for a few minutes, possibly to save resources. When they close the connection, FileZilla may show the info above, as Admin mentioned:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.