Free SSL is pending for a few days

Hello, I am newly registered here. I have this domain —, I was trying to set up the SSL on the same day when I signed up here. It didn’t seem too hard, but got stuck on the requesting stage. Did I do anything wrong, or should I wait more? Except for this SSL thing, I did not attempt anything else. I am just planning to install WordPress later.

Here is what I see on the SSL page. It has been so for more than 2 days.

Please do this


Hello, thank you for your reply. As far as I understand, I did the option 1 which does not have any other steps. This is a free certificate. Which step exactly do you mean?

I have applied for a free certificate, and it is still pending for more than 2 days

this is another image of what I see on my end

Strange, there should be one SSL cert available.

Can you try to apply for another SSL cert


Interesting :thinking:. I tried creating another order, Infinityfree website just sends me to the page with the pending certificate and nothing else happens. All other pages show that I have no certificates.

Able to do this?


I requested a new certificate by choosing one provider from the dropdown. It will take some time for the DNS changes. Now I will do all the stages again. I hope this issue is solved(

– small update
Request certificate button appeared right now, we’ll see how it goes. This process took longer with Google Trust than now.

Thanks for your help. The new certificate from a different provider has just been installed. No issues anymore.



I checked the issue. It seems like your order got stuck for some unknown reason. While we normally have checks in place to detect and retry such orders, that functionality wasn’t working.

It’s being fixed now, your order has been retried, and your Google Trust certificate is now available.


I also have my request pending for a week now.

It used to be just one request pending, but now there are 2. Is there anything else that I should do except to wait?

What do you see on the page when you click Manage next to you? Does it say the certificates are being created?


Flexible mode need to pay one time , full mode need to pay, full with strict mode valid certificate need to installed on origin hosting server i am free account hosting no access so i decided to off mode no secure encription i have just issued ssl certificate from infinityfree account but my domian website is redirecting too many times so goging to revoke issued ssl certificate from your hosting account. Give me suggestins.


I am not sure what you are talking about. You don’t need to pay to change your SSL mode setting in Cloudflare, and you don’t need to pay to get or install a certificate on InfinityFree. It’s all free.

I recommend installing a self-signed certificate in InfinityFree, and setting your Cloudflare SSL mode to “Full”


There is a button to request the certificate. I was ignoring this, because I thought I already requested it and I did not want to send multiple requests.

I clicked it and the next step to install it automatically. It is now active.

Thank you very much!

1 Like

Thanks for the feedback. I’ll think about changing the text on the button to make it more clear that it’s the button that continues the process, and it doesn’t just create a new order.

Any suggestions on what would be a better label? It already says this next to the button:

Click the Request Certificate button to start the issuance process


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.