Filezilla FTP won't connect even after disabling TLS

I realized that MONSTA FTP won’t upload the images and I get an error every time I try to upload images, so I decided to use Filezilla (my fav FTP tool) instead simply won’t connect to the FTP.

I was getting this:

Error: GnuTLS error -110: The TLS connection was non-properly terminated.
Status: Server did not properly shut down TLS connection
Error: The data connection could not be established: ECONNABORTED - Connection aborted

First, I checked Filezilla troubleshooting and I realized the problem was that I had to disable “secure” TLS connections. After selecting “Only use plain FTP (insecure)” hit Okay > accept all the warnings bout insecure connections > still not connect. I got this:

Status: Connection established, waiting for welcome message…
Status: Plain FTP is insecure. Please switch to FTP over TLS.
Status: Logged in
Status: Retrieving directory listing…
Command: PWD
Response: 257 “/” is your current location
Command: TYPE I
Response: 200 TYPE is now 8-bit binary
Command: PASV
Response: 227 Entering Passive Mode (IP)
Command: MLSD
Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

USER: epiz_******
PASS: *****
PORT: 21

Any idea why this is happening?

Thank you

You should not disable secure FTP connections unless you absolutely have to. The TLS error you saw initially is just your connection being kicked out for inactivity, just not quite so clean because of the encryption. But you should still keep encryption enabled.

So, in other words, all of the errors you’re showing here are completely normal.

What else do you see when you try to connect to the FTP server? Does the file and directory list appear? Are you able to start a transfer?

Can you please elaborate on this? What error do you get and how does that mean that MonstaFTP won’t ever work?

Thanks for ur reply :slight_smile:

If I disable the plain FTP, it just won’t connect. I’ll get the GnuTLS error- 110 every time

When I disable TLS check, I CAN reach the “Logged in” Status — but when it shows: “Retrieving directory listing…” nothing comes up and then I get the t/o message:

Error: Connection timed out after 20 seconds of inactivity
Error: Failed to retrieve directory listing

MONSTA uploads the images Folder, okay, but Empty. When I try to upload the images manually I get an error “file not found”(?) which is super weird.

Tried drag n drop, hit the upload button, etc — but still the same. Btw, deleting the folder images
from the directory will show an error “File not found” as well xD


Try use this setting for filezilla…


Trust the self-signed SSL cert when prompt appear…

1 Like

I don’t think encryption is the problem here. After all, it’s not like unencrypted FTP does work correctly.

I can test your account to see if I can connect to it. Can you please specify your account username or domain name so I know which account you’re talking about?

The SSL certificate for is not self signed. It’s a trusted certificate signed by Sectigo. If you see a self signed SSL certificate, then it means someone is hijacking your FTP connection and you should abort the connection immediately.


Thanks, KangJL … I tried it, but I got the same results.

Error: GnuTLS error -110: The TLS connection was non-properly terminated.

Idk, pretty weird … I remember this happened to me a long time ago with another server, and I think I completed the Host text field with an IP that the host gave me and it worked (instead of ftp://blablabla).

Thanks, Admin

Sure, you may check it. Username: epiz_27699666 . I appreciate it

You could try using or as the FTP hostname instead.

I just checked your account and I don’t see any issues there. I was able to connect with FileZilla (with encryption) without any issues.

Also, I see that you uploaded other files already too. Were you able to connect successfully before? If so, what changed?

1 Like

Thanks, I’ve just tried those. Still not working :confused: … the same TLS conn error. I’ll install a different version of Filezilla just in case.

Yes, I did upload all the folders and files with no probs using MONSTA instead :smiley: . However, when I try to upload the images they just won’t upload (tried: .svg, .png, .jpg) all the same.

Thanks :slight_smile:

Whew…cert seems legit

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.