File manager error: 421 Home directory not available - aborting

You can’t move your account to a new host, only your domain!

dude… My old account has some troubles with file system so i created new infinityfree client account. And created new website with fresh domain, but I can not connect to FTP so do you know what to do to this error message ? " 421 Home directory not available - aborting"

Ok, so your having that error on your old account, and created a new one to try and fix that. This sounds like some sort of server issue if it happened more than once. Hopefully Admin will we able to get it fixed quickly.

1 Like

still couldn’t fix the problem

@nothingtosee1, this is a known issue with new accounts at this time, as hopefully the fox will be soon.

I can’t, this problem still exists

The problem you have just means that InfinityFree doesn’t create the directory on the ftp server when your account is created.

So on login it fails to chdir to a non existing directory which also means logging in fails.

Obviously, the directory has to be created manually, but that kind of request to the staff is only possible through prenium. Looks like you have to upgrade to prenium.

InfinityFree is free only if it works so not in your case.

What’s your point with this? Are you trying to say “Go buy premium InfinityFree is no longer a “free” hosting website that’s why root folder failed to create during the account creation, not because our system has a bug of course…”

Yep, if there’s a bug which only happens to you, then you need paid support to solve it.

I guess you are just someone who paid for premium and trying to announce it to the community :slight_smile: Btw this is not only happens to me, if you check the other topics you can see this is a global problem, have a nice day…

@lcellier, you DO NOT have to buy premium hosting to solve this. This is a temporary server error, and should be resolved quickly. This has happened before, and has evidently happened again. IT WILL BE FIXED.


If quicky is more than 24 hours then it’s not that quick :frowning:

1 Like

I get same error:

Command: USER epiz_28631110
Response: 331 User epiz_28631110 OK. Password required
Command: PASS ************
Response: 421 Home directory not available - aborting
Error: Could not connect to server
Status: Waiting to retry…
Status: Resolving address of
Status: Connecting to…
Status: Connection established, waiting for welcome message…
Response: 220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response: 220-You are user number 227 of 6900 allowed.
Response: 220-Local time is now 19:01. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220 You will be disconnected after 60 seconds of inactivity.
Command: AUTH TLS
Response: 234 AUTH TLS OK.
Status: Initializing TLS…
Status: Verifying certificate…
Status: TLS connection established.
Command: USER epiz_28631110
Response: 331 User epiz_28631110 OK. Password required
Command: PASS ************
Response: 421 Home directory not available - aborting
1 Like

I’m getting the same error message. Created a free account today off a friend’s recommendation but can neither get into the remote directory via the Online File Manager nor FileZilla. Called my friend up and he can’t also get into the new hosting account he created today. He can however get into his old hosting account via both FTP and the online File manager.

Anyone gt any idea on how to resolve this?

Hello @MarfoRobert, this is a known server error, and should be resolved shortly. Unfortunately, there is nothing you (or anyone else besides staff) can do.

1 Like

You can’t fix it its a server Side error Infinity free cant create root folders but you can still access old accounts ftps because they already has root folder which created before without any trouble.

1 Like

I too got the same response but I saw a person saying that it’s a mistake from their server side and it will be solved :grimacing: But I don’t know when.
I anyones problem got solved them please ping me

In case staff are monitoring this thread and fixing these problems on an account-by-account basis, I am getting the same problem with the new account I created yesterday. Everything works fine, except for connecting to FTP, which gives “421 Home directory not available - aborting”, even when I try connecting directly to “/htdocs”.

I just hope that as Greenreader9 said, it will be resolved shortly.

Hey @SirMandorallen, does this mean softaculous works for you?

I had not checked yet, but it does not seem to work, I get: “Something went wrong, please allow 20 minutes then retry”.

If I try to configure PHP, I get: “Configure php directives It appears the document root for the domain name does not exist, please contact support 89347349288”.

1 Like