Failed to add domain with special characters


Error Message

Validation error

International domain names (with non-Latin characters) are not supported on free hosting.

Other Information

When I try to add my domain I get the following error. How should I register my domain so that it is configured correctly? I have checked that the nameservers are pointing correctly.

No, it is not

I believe that this is an inconsistency between the new account API and the hosting itself. I think you can create an account with another domain first (a free subdomain is fine) and then add this domain name afterwards from the control panel.


I think that if you convert it to punycode it would work when you sign up.

If I want to create a new account I get the following error if I put the url with punycode.

Instead I have tried creating an account with a subdomain and then adding my domain but I get a different error.

I have the nameservers pointing correctly to:

What does the error say? I can’t read Spanish, and I can’t translate it from a screenshot.

Also, as you can read on the page: changing nameservers can take some time to take effect.

Here you have. I keep in mind that it can take 72 hours to change the nameservers but I have left them even longer and it continues to pull this out. There is no way to add my domain and I don’t know how to do it.

Also as I have put in the thread of this forum, I have checked the domain with the panel tool and I get that it is pointing to the nameservers correctly.

The WHOIS information of your domain name shows this:

Updated Date: 2021-08-05T15:03:53.000Z

I don’t know what was updated at that time, but I thought it were the nameservers.

The nameservers seem OK as far as I can tell, but it’s entirely possible the control panel checks it in a different way than I do or than the client area does.

So how can I proceed to add my domain?

If it is due to an error in the development, could not a ticket be opened for it to be fixed? Otherwise I will have to look for another hosting.

Do you have the domain connected to a different account, anywhere? (Including deactivated ones, and on different hosts). If so, remove it.

Ensure your nameservers are still set correctly. (If they are, do not touch them)

Once you verify these, try adding the domain to the account under the “Parked Domains” or the “Add-on Domain” section. If you still get the error, try a different browser or clearing the cache and cookies.

Let me know if anything works!

There is no way, in both places I get an error and if I try to add it directly to an account I get this:

Therefore I would say that it should be for the free account, but how am I going to pay if it will not work for me later …

Please try adding the domain under the "Parked Domains” section in the control panel of a new account. Try adding the domain with the non-English characters first (So as one would type it into the URL bar), and if that dosen’t work try adding it with Punycode.

With Punycode this happens to me:

Without Punycode I get the same error in red with the following text:
Characters not allowed in domain …

I guess your domain is not supported than…

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.