Failed SSL Cerificate

SL certificate error: The required CNAME records were not found. Please add the CNAME records and keep them active until at least the certificate is issued.

Please tell me how to fix this error since I have tried 3-4 times today and the same error is coming. I also cannot change which provider gives the certificate.

Just wait a few hours and try again. DNS checks can be a bit flaky shortly after adding the records due to DNS cache.

You can select the provider if you click the New SSL Certificate button, and you open the Advanced Options. The retry button on the failed order will create the order exactly as-is, including the provider.

I recommend against using a different provider through. Google Trust is our recommended provider for a reason, and the error you’re seeing means our system is rejecting the order before it’s even being sent to the provider. Choosing a different provider will do nothing to fix this issue, and will give you all the limitations that provider has that made us not designate them as the recommended option.


Got it, I will check again if it is working now. Thanks for the help

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.