Error on plugin activation

I am getting this error message: require_once(): Failed opening required 'htdocs/wp-content/plugins/td-composer/legacy/Newspaper/includes/td_config.php' (include_path='.:/usr/share/pear/'). Could you please help me with it? Please ask me if you need any more information.

Could you please refer to this Article?

1 Like

First of all, Thank you so much for your reply. I have already tried those stuffs. I have installed the plugin by hand. Still I can’t activate it because of that error. The same process was done with my friend’s website which is in premium hosting. Everything is fine there. Everything worked perfectly there. Could you please check from your side once?

It clearly says some files are missing. That’s why i suggested you manual installation (uploading files via FTP).

1 Like

Every single file is present on the server. Could you please explain to me about this. (include_path=‘.:/usr/share/pear/’)

Please check that /wp-content/plugins/td-composer/legacy/Newspaper/includes/td_config.php' directory exists.

It’s a system directory.

Yes, it does.

Then what’s the full error code? No such file or directory or access denied?

An error of type E_COMPILE_ERROR was caused in line 17 of the file /home/vol15_1/ . Error message: require_once(): Failed opening required '/home/vol15_1/' (include_path='.:/usr/share/pear/')

I checked the folder at htdocs/wp-content/plugins/td-composer/legacy/Newspaper/includes/, and there is no td_config.php file there. Can you please check the plugin folder on your own computer and check if the td_config.phpexists in there? If it does, can you please try to upload it?

And if the file is not there, that means the plugin you’ve downloaded it is just broken. You could try an older version or ask the plugin developer about this.


Ig just not checking a thing also confuses who wants to help you and will delay.

Hello, Admin. Thanks for replying to this post.

As you said, I have checked the plugin folder on my own computer and checked if the td_config.php. exists in there. And it does. I did re-upload the file and the error is still there.
The plugin developer has already suggested me to contact my hosting provider. If you require then I will also provide you the Wordpress Login Details. Thank You in advance.

And one more thing. When I activate WordPress’ Default Theme then the plugin works perfectly fine.

Hey, I found the main cause. As soon as I upload the td_config.php file, it deletes itself. If you could just help me keep that file permanently, then the issue is solved.

Thanks to everyone who helped me throughout the process. The Problem has been solved.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.