Error 525: SSL handshake failed

My website URL is:

What I’m seeing is:

I’m using this software:
Chrome Browser

Additional information:
it was working fine but after I change the wordpress website address and site address to https from http. it refreshed the page after saving and I was loocked out

okay so I see now that the site is working, but I can’t access wordprees admin dashboard. It says: This site can’t be reached ’s server IP address could not be found.


Additional Info: to get the site working I changed cloudflare ssl to flexible from full

I see redirect loop

Please read this and use FLEX :

  1. If you configure your WordPress site to use secure connections, then WordPress will redirect people if it detects an insecure connection. Cloudflare by default uses Flexible SSL, which means the connection between you and Cloudflare is encrypted, but the connection between Cloudflare and your website is not. WordPress detects this insecure connection and will try to redirect the visitor to the secure URL. Even if the visitor is already using a secure connection on the other side of Cloudflare.

To fix this, you could try the following:

  1. Change the WordPress Site URL to NOT use https:
  2. Login to the Cloudflare website, find your domain, go to the Crypto tab and enable “Automatic HTTPS Rewrites” and “Always Use HTTPS”.
  3. Try to open your website in private browsing mode. This will help to circumvent any bad redirects cached by your browser.

unless the problem is some additional plugin


Hello, thank you for the response. However, I can’t find crypto tab. What Im seeing is: overview, analytics, dns, ssl/tls, firewall, access, speed, caching, workers, page rules, network, traffic, stream, custom pages, apps and scrape shield. Please advise. Thanks in advance

The “Crypto” tab is now named “SSL/TLS”, and the “Always Use HTTPS” and “Automatic HTTPS Rewrites” options are in the “Edge Certificates” page of that tab.


Thank you. Site working and secured. done and done! I’m so grateful:smiley: to all ya’ll.


Hi guys I don’t know if this is relation to the 525 error. But, after I got the site working (thanks again for your help with that regard) I am now unable to add pages or posts. I tried adding the classic editor plugin but even that isn’t working properly and won’t allow editing in the body of the page/post. Can You Please Help Me. I’ve been trying for 5hrs to find something that works, but I’m falling short…Please help?

hello again I have been able to solve the problem mention in previous post using a plugin. thank you.

1 Like

Would you mind sharing which plugin solved the issue for you? We’ve seen many people have issues with Flexible SSL and WordPress, and it would help those people a lot if you know of a plugin helps with that.


Hi i used the Really Simple SSL plugin, aslo enabled “Mixed content fixer”, “WordPress 301 redirection to SSL” & “301 .htaccess redirect” including “Use alternative method to fix mixed content” inside the settings of the same plugin.

Hello all, there seems to be another problem with site when one enters;

the site works fine but you enter:

you get:

This site can’t be reached ’s server IP address could not be found.


Please help

That’s because you didn’t create any DNS records in Cloudflare for the www subdomain. You’ll have to create one yourself, and point it to the same destination as your base domain.

1 Like

Hi could you please talk me through below quoted process.

Thanks in advance

1 Like

I figured it out. Site working. Thank you so much, I learned and had fun. Thanks again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.