Epizy.com subdomain - unable to set up ssl because dns not verified (CNAME)

Website URL


We couldn’t identify the nameservers of your domain name.

Please set up the CNAME records at your domain’s DNS provider.

The current nameservers of your domain are: dns1 namecheaphosting com, dns2 namecheaphosting com.

Record Name _acme-challenge
Domain davesweb- -eipzy com
Destination 4b80a3e7-32d0-44dd-8801-98f870fbf491.acmedns.infinityfree.net
Current Destination (no CNAME found) Not Ready

I can’t see anywhere that I can do the CNAME entry myself - is there?

[further error - I can’t put in more than 2 links so I had to edit the error message a bit]

Please make sure you are requesting for the correct subdomain.

is definitely not


Yes I said I had to alter the message due to only being able to have 2 urls in a post

Regardless of making the URL not be visible as a URL, you requested an SSL certificate for davesweb.eipzy.com, which is not davesweb.epizy.com.


If you enter the right domain name, you’ll also see the option to setup the CNAME record automatically. But since the domain you have entered is not actually the domain that’s hosted with us, you’re instructed to set it up yourself instead.

To avoid typos like this, you can also use the SSL/TLS menu on your account in the client area. If you request a free SSL certificate from there, you don’t need to enter the domain name yourself.


Thanks fo rreplying. Sorry I just can’t see the difference " davesweb.eipzy.com , which is not davesweb.epizy.com ." they look the same to me.
I tried copying the second one and pasting it in but got the same result.

I was selecting let’s encrypt - I just changed it to “recommended provider” abd it worked. I thought lets encrypt was the only free one. Seems like lets encrypt doesn’t accept the url

Thanks I’ll be ok now I think


Please compare the second and third letters of both domains. Especially the order they are in.


Ok see it now!
I was using the wrong provider it seems anyway.
Its all working now thanks

If you entered your actual subdomain, then Let’s Encrypt would not have been available. But if you enter a different domain, you may get a different provider selection.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.