Email Server Issue


I have some questions regarding the mail server system:

  1. How long should it take for the MX record to propagate through InfinityFree systems? I have followed all the steps needed to to make it work and have created the MX record with my DNS provider as well as setting it up for my domain name on Cpanel. It has been over 8 hours - is this normal or should I do something? (Common problems might help if it shouldn’t take this long).

  2. This one might link in with the issue I mentioned above. I have created some email accounts on the mail system and have tried to login to them through the roundcube link provided. They don’t work. Is this because the MX record isn’t yet fully propagated?

Thanks a ton,

The MX record may propagate immediately on some cases; to test the emails use, where you can send emails to the email address and get the results. However the MX records affect only receiving emails, not logging in the webmail.


I have attached a screenshot from 123-reg (the people I bought my domain from - this shows that the MX record is setup) I have also attached a screenshot from Cpanel - showing my domain is setup. Do you notice any issues?Screenshot_20190630-193857

Now I’m getting this when I try to login:

Also I heard that Cloudflare breaks the email service so I have tried disabling that - but it just seemed to make the email server disappear.

Any ideas?

EDIT: I have reenabled cloudflare for security but once a possible solution arises I will disable it again if need be.

Enable cookies on your browser or use a browser that has cookies enabled to login to the webmail.

Cookies are enabled. I have checked.

Then go to, without putting ?i=1, ?i=2 or ?i=3 variables after that!

I login normally and then get sent right back to the same page. :confused: (404)

UPDATE: I tried on a different device (more updated) and found that it works slightly better. However, on this device when I try and login it says “Invalid Details” (or similar) and refuses to let me in even though the entered details are definitely correct. I have tried using “[email protected]” and “my email” as the username but nothing seems to work. Any ideas on how this issue can be fixed? Also the MX record is still broken - if anyone knows how that can be fixed.

The Google errors have disappeared now but I still can’t login.

Account Name: epiz_24119999

If any InfinityFree staff can take a look I would greatly appreciate it. I believe the email server is somehow broken.

EDIT: The Google error still appears sometimes and the MX record might not have propagated. I have contacted 123-reg and asked them to investigate the MX record issue. However I still believe that there is an issue with the mail service. If I have time later then I will try logging in via FTP and seeing if I can fix it (unlikely, but worth a try I suppose).

I am now able to send emails from a new email address, but cannot receive them.

The cPanel integration of Cloudflare is known to block MX records and subdomains creation. So I would suggest to remove the site from their integration of Cloudflare, go on and add the domain there, then change the nameservers from 123-reg / InfinityFree ones to their ones.

A few points I would like to clarify:

  • Your domain name is currently using Cloudflare’s nameservers. That means that any DNS records for your domain name must be configured through Cloudflare. While you can also configure DNS records through our panel and through your domain registrar’s panel, those settings don’t affect your domain name (unless you change the nameservers).
  • That said, your domain is currently using as the MX record, which means that incoming email will be delivered to us, and should be delivered to your email accounts.
  • MX records control which email provider (if any) will receive email for a certain domain. MX records do not control sending email or webmail access.
  • The Google cookies page means your browser doesn’t accept cookies from the webmail URL. Please check your browser’s settings to make sure there is nothing blocking cookies from being set.


On most platforms it works fine now. I had to delete all the old accounts because they stopped working - but they work fine now I remade them. Appeared to mostly just be a waiting game.

Also, I have a few more questions about the email system now:

Thanks for all the help so far,

You can’t add plugins on their webmail because they disabled the FTP access to it. I don’t also know how to setup an autoresponder, so I can’t help with it.

Ok, thanks for the help.

Does anyone know if it is possible to create an autoresponder?

I’m sorry, auto responders are not supported on free hosting.

Hello I am having the same issue of not being able to receive but I am able to send MX records have been set for more than a day now not sure what to do just sort of wanna know if I have to wait longer or should I do somthing extra btw site is

I can see it’s propagated and has a MX record with as priority 0. Maybe change it to 10 next time and wait 24 hours.