Elementor not working

Hi there,
I am trying to edit my site with elementor - however, it is not working. It keeps loading until a pop-out at the bottom right asks “enable safe mode” - I click, it and I receive an error message. I tried clearing the cache and I updated all of my plug-ins, including elementor.

Please help as I need to edit my website - the images are not working!


Hi, Elementor requires lots of resources to run, therefore, most of the time, it won’t work.


It has been working for me for the past 4 months.

Likely some update broke it.
If you are using nulled software, be prepared to get suspended
If you really did pay for it, get support from the Elementor author.
For best experience, get premium hosting


? Elementor is a free plugin

Is WordPress also running the latest version? Did that update succeed? A new WordPress version was released recently which often results in many sites breaking because of failed upgrades.

What does the error message say?


Yes, WordPress is running the latest version. Yes, the update succeeded.

When I try to open the plug-in, it never loads and a message comes at the bottom right of the screen.

I click on “enable safe mode” and it says “an error occurred”

Did you read these?

If you keep insisting on using Elementor, you will always be facing the same issue.

still applies

Take note of this as well


Hi there,

I have read through these articles and followed all of the steps in them, but nothing worked. I don’t really care about elementor, as I don’t plan on editing my website - I just want the images to work. I have the WP-content, WP-config, and the SQL files on my computer, so if I can do anything with those, then please tell me. I have been trying to fix this for 2 weeks. Please help.

You have created multiple threads.
Do the actions required in this thread


One more thing. I believe the image files are corrupted. It failed to open up


I did nothing works

I know that.
Now my wp admin doesn’t work, so I cant reupload the files.

I actually cant belive this - nothing is working

What did you do?

Use filezilla


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.