Domain suspended for no reason

Hello everybody. They suspended my domain right after I created a new account. this is the suspended domain

As you can see, I have no deactivation

I honestly don’t know why this happened. If anyone knows, can you tell me how can I fix it?

(post deleted by author)

Can you show me where the suspension is? Note that new accounts take some time to set up and you may see the suspended domain page while that happens. Also note that new accounts are experiencing an FTP error right now, so you won’t be able to upload files or use softaculous until that is fixed.

the suspension is on this domain →
It does not appear in the Deactivation history

As I said before, new accounts take time to setup, and may show the suspended domain page during that process. Your website is not suspended and is ready to go!

If you do not see this screen, just clear your cache than refresh.


6 posts were split to a new topic: Domain suspended for no reason

Have you tried reading the big yellow banner that clearly says your domain can take up to 72 hours to start working everywhere?


Yes, you are right but being familiar with infinityfree, I have never had to deal with a suspension even 72 hours before

This is what you don’t understand; its not a suspension; Its due to DNS/Browser Caching. If you clear your browser cache, you may find that your issue is solved; if not then you will have to wait the 72 hours for the domain to propagate.


Your domain is not suspended. It clearly says so in the client area. But there are also other reasons why a domain may redirected to

In this case, I think it’s part of the ongoing system issues.

1 Like

Well, I am not sure if this is applicable here as my account is less than 72 hours old, but… I don’t believe these OPs are totally out of line here.

My website: worked fine last 2 days until I went to delete a couple files uploaded files from File Manager. Suddenly, the file manager hung. When trying to relaunch it, I got 502: Bad Gateway. Same for my site. Then, after it was previously working, my website starts redirecting to the suspended website, just like OP.

For reference, the FTP is hanging on my account’s password. If I use the wrong password, it denies me and doesn’t hang, but if I use the right password, it hangs. File manager now loads, but gives “Error: Could not read line from socket.”

So, I think there may in fact be an issue here, though I can’t imagine deleting my own prior uploaded files caused a crash?


It’s been ~30 minutes since the outage. I cleared all DNS / Chrome cache, am using incognito mode, have tried from 2 devices on 2 different internet connections. Currently, control panel shows my account is active, and the website works IF I specify “index2.html,” but the default / loads to a blank page. FTP passes USER command but hangs on PASS command IF the password is correct. File manager still says “Error: Could not read line from socket.”

I really don’t know what happened. my username is: epiz_28642365, website:

No more 502: Bad Gateway or suspended redirections though … so I’ll take that.

Any word on what’s going on would be great. If it’s just downtime due to some system issue, that’s fine, but front page claims 99.9% uptime, so I’d think this sort of general outage is rare which is why I am worried.

There are system issues. That’s what I described here:

The FTP login for your account seems to time out which I suspect is also a result of this.


Hi Admin,

Thanks for the reply. I’ll give it time and report back later.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.