Domain Name shows other website without www

My website URL is:

What I’m seeing is: with www website working fine. But without www it shows other website like advertisement.
I have checked ip address, it shows different.

=> - (

=> - (

I’m using this software: web browser (chrome and firefox. Both latest version)

Additional information:


There is no entry of * and how to give A record because in infinityfree hosting Cpanel there is just source and destination in CNAME.

you can see in this screenshot below

Try to remove and re-add the domain from the “Addon Domains” section of the Control Panel, upload your website files to yourdomain/htdocs with a FTP client, where yourdomain can be replaced with your domain, and then if the certificate can’t be found for your domain, try to reinstall it again by uploading the Private Key and the Certificate on the fields present on the “SSL/TLS” section of the Control Panel for your domain.


I just noticed that InfinityFree generating hidden CNAME (pointing to * for their customers new account/domain.
That’s why many their customers complain about his/her site redirects to an ad site.
Sometime the DNS gives correct value (A record), but sometime it doesn’t (CNAME record).

I just tested this on my new account.

1 Like

Now? what should I do for removing * :persevere:

I tried what you said but not worked.

For me it now works. Try to follow the instructions present on this article to fix that:

1 Like

Issue is still there, see and both working at different

are non www domain are sold by infinityfree to bodis?

See This,

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.