Domain name expired while hosting at infinityfree

Username (e.g. epiz_XXX) or Website URL

Had the old domain ( registered with namecheap, while hosted the site at infinityfree hosting.
Created everything all the necessary setup steps with parked domain and all, all were working really fine, except the certificate (which I didn’t care much at all) at that time.

Error Message

Now the issue is, the domain has expired, and I just now registered the new domain registered with another provider, made the following changes,

  1. Changed the nameservers to point to infitiyfree at that service, pointed to infinityfree nameservers.

  2. Created that domain in infinityfree to be parked at infinity free, as below

  3. Did the SSL certificate installation to self certified…

  4. Made the change in the htaccess file in the file manager, made the change from the line From below
    RewriteRule olddomain/wp-content/…
    To below
    RewriteRule newdomain/wp-content/…
    This setting I made to make sure I can securely use the site using ssl.

But now, if I tried to access the new domain, it take a while to load and the domain name is getting resolved to the old domain … which I removed it from my hosting at infinity free. And the site not loading rather, it shows “This site can’t be reached” page.

Other Information

To not, I registered the domain just yesterday, although it says it may take up to 72 hours for the change, with my previous experience it won’t take that long. Therefore, please help me fix this.
Also help with fixing the SSL certificate issue.

Thank you


If you’re moving a WordPress installation from one domain to another, you also need to update the website URL in WordPress. WordPress has their own article about that here:

This should stop your new domain from redirecting to the old domain.

What SSL certificate issue? In your message, I only see that you installed a self signed certificate. Are you having trouble doing so? Or did you do that successfully but did it not have the intended effect? If so, what were you trying to do?

Thank you for the suggesting solution steps, Admin.

But, I am bit confused as to, how I can access the wordpress admin page? it can’t be accessed through cPanel and the old domain is expired, so there is no way I can access it through that.

Yes, even after installing the SSL self certified certificates, the previous domain was opening up in chrome as http with a warning.

with the uril - I get to this page,

If I try to entrer the username and password and click the login, the address gets resolved to the olddomain/wp-login.php and resulting in “This site can’t be reached page” …
Please help.

if you read the article that the admin published in his previous post
you will see that there are 4 ways to do it


Thanks OxyDac, but not sure I’ve read it.

Finally I now have fixed the Issue.

Here are the steps of what I did,

  1. IOpened the myphpadmin from cPanel.

  2. Connected the database (only 1 database was there)

  3. under wp**-options , the options “siteurl” and “home” were still had the old domain name, I edited both the records and changed the records with the newdomain name.

  4. Then to reset the wp-login user name & password under wp**-users , edited the account, and changed the value of “user_pass” , selected “MD5” under the function and inserted my clear text passord in the “value” column, and then clicked “Go” (the clear text password became just some long charactors)
    Also changed the “user_email” to info@newdomain from info@olddomain (this is needed just to login to wordpress)

While I tried to login several times just pasting the hashed password which I copied from the wp**-users, section, it didn’t work…
It only worked when I tried to use the clear text password along with the new username/email address.

Thanks to everyone who tried to help, and hope these steps help someone in the future.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.