Domain locked onto host?

My website URL is:

What I’m seeing is: Domain is stuck on host.

I’m using this software: Windows 10

Additional information: I have a domain with ( I ran across an issue on this hosting, so I tried switching the nameservers back to the default ones for freenom, and it still shows my website on InfinityFree. In my 5+ years using freenom, it’s always taken less than an hour for the nameservers to update. It’s been almost two days now since I first tried to change it. They still haven’t updated. Shows my InfinityFree instead of the default freenom page. I’ve tried cancelling my hosting accounts, flushing my dns, clearing my cache, and even using incognito as well as multiple other devices to test the website. Still no signs of change. My domain is somehow locked onto this host.

Why is this happening?

For me it now shows the message you applied to your index.html file. If you also want to see the changes please clear your browser cache, flush your DNS cache or, if these solutions don’t work, configure a faster DNS resolver like, Google Public DNS, OpenDNS or Quad9 on your device.

1 Like

what does it say when you view it?

It says “If you’re seeing this, the host is no longer InfinityFree” when I visit your website now, with also a 000webhost powered by at the bottom right of your website, with my computer and phone on the same incognito tab, using a Level3 set of DNS configured on my devices ( and to be precise).

1 Like

I had my computer set to (Warp), however my router and modem both still had the defaults. Switching those did the trick, it’s showing the updated version for me in incognito now. Thanks a lot!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.