Disabling the ?i=1 Problem {SOLVED}

Many people here have asked for a way to disable ?i=1.
Well, I will tell you here how to do it:

How to disable ?i=1 Suffix without paying anything

First, enable CloudFlare through cPanel and Select the option Full SSL/Flexible SSL (**NOT RECOMMENDED**)/Full SSL Strict if you have your own certificate. It should be disabled in 2-24 hours! Also Admin, please update this article https://infinityfree.net/support/what-is-the-i-1-suffix/ and mention that with integrated CloudFlare, this gets automatically disabled. Hope I helped!

A logical explanation of why does that happen:
First of all, when you enable CloudFlare a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on InfinityFree, so it doesn’t have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn’t have it, it completely removes it until you disable CloudFlare.

When you disable it, or if you don’t use it at all (thanks to @UnknownLolz) the ?i=1 is back (:cry:). So, either you will have CloudFlare and you won’t have the ?i=1, or you will have to live with that annoying thing and the inavailability of your site through mobile apps.

You choose! Its up to you!

Note: @Rikhi55 this was the topic I was talking about.

@ChrisPAR said:
A logical explanation of why does that happen:
First of all, when you enable CloudFlare a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on InfinityFree, so it doesn’t have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn’t have it, it completely removes it until you disable CloudFlare.

When you disable it, the ?i=1 is back (:cry:). So, either you will have CloudFlare and you won’t have the ?i=1, or you will have to live with that annoying thing and the inavailability of your site through mobile apps.

You choose! Its up to you!

Note: @Rikhi55 this was the topic I was talking about.

Even if you don’t use Cloudlfare it’s still there.
My website before I used Cloudflare, it has this suffix on the web browser even if I’m not using Cloudflare.

@UnknownLolz said:

@ChrisPAR said:
A logical explanation of why does that happen:
First of all, when you enable CloudFlare a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on InfinityFree, so it doesn’t have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn’t have it, it completely removes it until you disable CloudFlare.

When you disable it, the ?i=1 is back (:cry:). So, either you will have CloudFlare and you won’t have the ?i=1, or you will have to live with that annoying thing and the inavailability of your site through mobile apps.

You choose! Its up to you!

Note: @Rikhi55 this was the topic I was talking about.

Even if you don’t use Cloudlfare it’s still there.
My website before I used Cloudflare it has this suffix on the web browser.

That’s exactly what I said!
If you disable or not use at all CloudFlare, it is there but when you enable it, it disappears!

@ChrisPAR said:

@UnknownLolz said:

@ChrisPAR said:
A logical explanation of why does that happen:
First of all, when you enable CloudFlare a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on InfinityFree, so it doesn’t have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn’t have it, it completely removes it until you disable CloudFlare.

When you disable it, the ?i=1 is back (:cry:). So, either you will have CloudFlare and you won’t have the ?i=1, or you will have to live with that annoying thing and the inavailability of your site through mobile apps.

You choose! Its up to you!

Note: @Rikhi55 this was the topic I was talking about.

Even if you don’t use Cloudlfare it’s still there.
My website before I used Cloudflare it has this suffix on the web browser.

That’s exactly what I said!
If you disable or not use at all CloudFlare, it is there but when you enable it, it disappears!

I use Cloudflare and it still has the suffix.
All of my website is using Cloudflare and there is still a suffix and it won’t change.

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:

@ChrisPAR said:
A logical explanation of why does that happen:
First of all, when you enable CloudFlare a CNAME Record is added so that your domain points to:
yourdomain.com.cdn.cloudflare.net

That is very important, because that new domain is not hosted on InfinityFree, so it doesn’t have the ?i=1 suffix, and because of your domain pointing to there, your main domain also doesn’t have it, it completely removes it until you disable CloudFlare.

When you disable it, the ?i=1 is back (:cry:). So, either you will have CloudFlare and you won’t have the ?i=1, or you will have to live with that annoying thing and the inavailability of your site through mobile apps.

You choose! Its up to you!

Note: @Rikhi55 this was the topic I was talking about.

Even if you don’t use Cloudlfare it’s still there.
My website before I used Cloudflare it has this suffix on the web browser.

That’s exactly what I said!
If you disable or not use at all CloudFlare, it is there but when you enable it, it disappears!

I use Cloudflare and it still has the suffix.
All of my website is using Cloudflare and there is still a suffix and it won’t change.

Please give me some links to check, I have tried this and it was always successful!
You can get this one https://signaldatabase.cf/, it is hosted on a MOFH hosting (mine!) and it doesn’t have the suffix.

And the only thing that I could remove this is to make a redirect.
Example:
when someone visits my website and my website loads with the suffix the redirect will redirect it with no suffix and it has worked for me.
But I don’t use it cause I actually don’t care about the suffix.

@UnknownLolz said:
And the only thing that I could remove this is to make a redirect.
Example:
when someone visits my website and my website loads with the suffix the redirect will redirect it with no suffix and it has worked for me.
But I don’t use it cause I actually don’t care about the suffix.

Give me a link to check please, if you have CloudFlare AND theirs SSL the suffix cannot exist!
Give me some of your links, I need to check please.

@ChrisPAR said:

@UnknownLolz said:
And the only thing that I could remove this is to make a redirect.
Example:
when someone visits my website and my website loads with the suffix the redirect will redirect it with no suffix and it has worked for me.
But I don’t use it cause I actually don’t care about the suffix.

Give me a link to check please, if you have CloudFlare AND theirs SSL the suffix cannot exist!
Give me some of your links, I need to check please.

polandball.ml

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:
And the only thing that I could remove this is to make a redirect.
Example:
when someone visits my website and my website loads with the suffix the redirect will redirect it with no suffix and it has worked for me.
But I don’t use it cause I actually don’t care about the suffix.

Give me a link to check please, if you have CloudFlare AND theirs SSL the suffix cannot exist!
Give me some of your links, I need to check please.

polandball.ml

You should clear your cache!
It has no suffix for me, I can even post a video where I visit the site in Incognito Mode to prove it!

@ChrisPAR said:

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:
And the only thing that I could remove this is to make a redirect.
Example:
when someone visits my website and my website loads with the suffix the redirect will redirect it with no suffix and it has worked for me.
But I don’t use it cause I actually don’t care about the suffix.

Give me a link to check please, if you have CloudFlare AND theirs SSL the suffix cannot exist!
Give me some of your links, I need to check please.

polandball.ml

You should clear your cache!
It has no suffix for me, I can even post a video where I visit the site in Incognito Mode to prove it!

Are you sure???
I visit it and there is still there.
I’ll try clearing cache then…

Apparently this is true!
We have an answer here everybody! ?

I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

@UnknownLolz said:
I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

Thanks!
I can’t stop laughing for some reason! -Probably because I didn’t expect to say this to you:

You should clear your cache!

@UnknownLolz said:
Apparently this is true!
We have an answer here everybody! ?
Is it true that the ?i=1 gets removed when you use cloudflare?

@ChrisPAR said:

@UnknownLolz said:
I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

Thanks!
I can’t stop laughing for some reason! -Probably because I didn’t expect to say this to you:

You should clear your cache!

@UnknownLolz said:
Apparently this is true!
We have an answer here everybody! ?
Is it true that the ?i=1 gets removed when you use cloudflare?

Hey that’s rude for laughing at my Comment, JK.
Yes I used Cloudflare directly tho, not the cpanel integration.

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:
I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

Thanks!
I can’t stop laughing for some reason! -Probably because I didn’t expect to say this to you:

You should clear your cache!

@UnknownLolz said:
Apparently this is true!
We have an answer here everybody! ?
Is it true that the ?i=1 gets removed when you use cloudflare?

Hey that’s rude for laughing at my Comment, JK.
Yes I used Cloudflare directly tho, not the cpanel integration.

I wasn’t laughing at you or your comment, you misunderstood me :neutral:
I could not believe that it worked without issues, I never had something with you.

@ChrisPAR said:

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:
I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

Thanks!
I can’t stop laughing for some reason! -Probably because I didn’t expect to say this to you:

You should clear your cache!

@UnknownLolz said:
Apparently this is true!
We have an answer here everybody! ?
Is it true that the ?i=1 gets removed when you use cloudflare?

Hey that’s rude for laughing at my Comment, JK.
Yes I used Cloudflare directly tho, not the cpanel integration.

I wasn’t laughing at you or your comment, you misunderstood me :neutral:
I could not believe that it worked without issues, I never had something with you.

Oops, I have misunderstood you.
But it was actually okay if you have laughed if there is valid reason.
Sorry though.

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:

@ChrisPAR said:

@UnknownLolz said:
I also visited my other website that are using Cloudflare with different browser with no clearing cache.
So this Answer is an upvote from me!

Thanks!
I can’t stop laughing for some reason! -Probably because I didn’t expect to say this to you:

You should clear your cache!

@UnknownLolz said:
Apparently this is true!
We have an answer here everybody! ?
Is it true that the ?i=1 gets removed when you use cloudflare?

Hey that’s rude for laughing at my Comment, JK.
Yes I used Cloudflare directly tho, not the cpanel integration.

I wasn’t laughing at you or your comment, you misunderstood me :neutral:
I could not believe that it worked without issues, I never had something with you.

Oops, I have misunderstood you.
But it was actually okay if you have laughed if there is valid reason.
Sorry though.

No problem :smiley: