Curl Error 60

Username epiz_28122022

cURL error 60: SSL certificate problem: unable to get local issuer certificate

I am getting this cURL error while using really simple ssl plugin and wp-optimize plugin . I came across that it may be solved if i use Cloudflare I am using cloudflare so want to what should i do in cloudflare cloudflare to solve this error .

Can you please send your website’s URL? Thanks.

Did a little more looking for you…

Try going to the SSL/TLS section of Cloudflare and click on “Flexible or Full SSL” for your SSL.
Note: Make sure your domain nameservers are pointed to Cloudflare 1st. (How to use cloudflare)

1 Like

My website URL is

I thinks when i point the namserver of my domain to cloudflare then i get ’ *cURL error 35: error:14094438:SSL routines:ssl3_read_bytes:tlsv1 alert internal error ’

So in either case i am getting a problem … curl error 60 ( if i use infinity free ssl and nameserver ) or curl error 35 ( if i use cloudflare universal ssl and point nameserver to cloudflare )

If I get a solution of either of the error ( curl 35 or curl 60 ) it would be helpful .

This issue is due to the most recent OpenSSL Update. Its an actually an error telling the remote server, or the domain that cURL is requesting doesn’t have a valid SSL Certificate. In simple, a cURL Error 60 is not strictly the fault of the hosting you use.

Fixing this with ReallySimpleSSL is a bit of a difficult one. They don’t provide a clear way of disabling SSL Checking when using cURL. From looking around I believe a possible fix is by disabling ReallySimpleSSL and keeping HTTPS, however I cannot be certain on this one.


Thanks for your reply . But can you tell how to delete how to delete infinity free ssl .

I have another site ( ) in that cloudflare ssl is activated and i am not getting any error , no curl error 35 nor curl error 60 . So i thought to activate cloudflare ssl in my main site ( . Even though i tried to do the same steps (installed cloudflare ) that i did in website . but then also cloudflare ssl is not activated .

I tried to delete the ssl key from the infinity free control panel but cloudflare ssl didnt get activated … infinity free ssl is active even though i deleted the infinity free ssl certificate key from infinityfree control panel

Can you help me to remove the infinity free ssl and activate cloudflare ssl ?

No need to delete.
Just follow the guide below to use CF…


Make sure to click the orange cloud until it goes gray ? what is gray cloud here ? is it the proxy status shown when i add a dns in cloudflare . Do i have to set it to ’ DNS only ’ instead of ’ Proxied ’ ?

If you want the benefits of Cloudflare leave the orange cloud untouched.


I have done everything that is possible . but i couldn’t solve curl error 60 . I even try the intergrated Cpanel Cloudflare and the Cloudfare where we have to point the cloudflare nameserver . Please anyone help to solve this error . i dont know why am i getting this error .

I wrote something about the cURL error 35 issue a few days ago. I think you’re having the same issue, so maybe the answer helps you too:

As for the cURL error 60, please note that Cloudflare takes up to 24 hours to issue SSL certificates for free domains. So maybe you’ll just need to wait for Cloudflare to finish the setup and then it works.


I found a way to solve cURL 60 certificate problem .
I tried the following way and the problem got fixed . If we use the integrated Control panel Cloudflare then we can solve this error . I enabled the Cloudflare Universal SSL and waited for about 24 Hours and the error got fixed .

And For error 35
I found that if i enable the ’ Always Use HTTPS ’ feature in the cloudflare then we get that error . So instead of that i used the Really Simple SSL plugin to use https .

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.