Couldn't add domain

Username (e.g. epiz_XXX) or Website URL

Error Message

This site can’t be reached ’s server IP address could not be found.

  • [Try running Windows Network Diagnostics](javascript:diagnoseErrors()).


Other Information

I bought on 10th june 2020 and changed nameservers to “NS1.EPIZY.COM” and “NS2.EPIZY.COM” but still when add domain in cpanel’s addon domain but its showing error “This could be due to already adding the domain to this or another account or, you have not changed the nameservers as required or not enough time has passed since changing the nameservers…”. I created a subdomain because there is a delay in domain nameserver’s change.
Please help me in finding the solution on how to fix this.


Please note it might take upto 24 hours to change.

Its 4 days now i changed nameservers on 10th June

Your domain still doesn’t point to our nameservers. Maybe try to contact Freenom in order to check whether the nameservers are set on your domain?


Please remind that DNS propagation is not complete, it may take up to 72 hours

Your nameservers are still:

Kindly change it or point it to Infinityfree nameservers.

I have tried to register a .ml domain on freenom earlier, and It’s succeed to point it into Infinityfree, no errors.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.