Connecting an IF subdomain to a Minecraft server?

Hey! :wave:

I just recently claimed a domain at I would like connect this domain towards my Minecraft server. (im not very fond of the subdomain the server host uses)

'Most all the tutorials I find on Google and the server host’s official YouTube say I need to use SRV Records, which I just can’t seem to find on InfinityFree.

How can I go about doing this?
~ Thanks, Xero.

Not available on free hosting

You can’t unless you upgrade to premium hosting



@Shocked, free hosting from Infinity Free is only for hosting real and legit websites on their servers. You cannot assume to use their free subdomain system to point to a Minecraft server! Also, there is no way to change the DNS A record in cPanel. Please understand the terms of free hosting by reading the following documentation:

You may be able to use the CNAME records tool for this. If your game server host has provided you with a hostname like, you can create a CNAME record for and point it to that server name.


Thanks, I’ll try this!
I’ll let you know if it works!

This worked…but also it didn’t.

See, I created a CNAME for and pointed it to
This worked, but not really. When I joined in Minecraft, it took me to the server at just (without the “waars” subdomain.)

How can I fix this?
Thanks in advance!

Likely due to this…

You need to check with game server host

The game server host doesn’t host websites…does that make this impossible?

1 Like

Likely as websites and game servers use different ports as well

1 Like

Nope, that’s completely unrelated.

I just checked and there doesn’t appear to be a CNAME record now. Can you please restore it so I can see if it’s configured OK?

It’s also possible that this doesn’t work. I’m not an expert on Minecraft hosting or game server hosting in general. I don’t know if or how multiple game servers can be hosted on the same IP address and what needs to be set up to make that work. That said, itself also has a few different CNAMEs, so perhaps it could work.

Alright, I’ll do that now

I just checked and there doesn’t appear to be a CNAME record now.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.