Comodo SSl Error

hey, i have generated a ssl certificate from Comodo i am completely noob in this but as i read in a infinitydiscussion form that i have to install all the files i received from comodo

as i only upload the mydomian crt it will be uploaded without any error but there is no https:// padlock appears (i have waited 2-3 hours after uploading ) and checked after deleting cache and cookies too and also with mobile too but no certificate found

then i can to know that i have to upload all the certificate one by one in one text including begin certificate and end certificate and still no luck it came up with the error ( It appears this certificate is in pem format / requires intermediates to function, this is not supported on free hosting )

i uploaded in the same format as mentioned in the previous discussion of comodo certificate please help me . i used smartcom certificate before but that was not supported by most of major browsers including opera , CM browser , UC browser . so i don’t want that certificate to be used on my domain i just want a simple and free ssl certificate which will work and gives a green padlock so my visitors feel safe i am new and want try everything before investing if worked for me than i will able to invest money on my website but this stage i really want to give it a try . and i also tried cloudflare but the cloudflare says that my certificate is active but there is no padlock there too

followed this instruction to upload comodo ssl

December 2016
In the “certificate” box you should not just enter your certificate, you should also include the intermediary and CA certificates you received from Comodo. When your SSL certificate was issued, you should have received an e-mail with a zip file attached which contains the certificates.

You’ll want to create a single text file containing all the certificates in the order:

  1. Your domain certificate.
  2. COMODORSADomainValidationSecureServerCA.crt
  3. COMODORSAAddTrustCA.crt
  4. AddTrustExternalCARoot.crt

Each of these files should be copied in exactly as is (including the BEGIN CERTIFICATE and END CERTIFICATE lines). So the file should look like

first certificate
second certificate certificate
Then, paste result of combining all these certificates into the Certificate box.

and come up with this error : It appears this certificate is in pem format / requires intermediates to function, this is not supported on free hosting

Please see this article:

same issue here too sir.