.co.za domain



Error Message - Change your nameserver to - ns1.epizy.com

Hi, I have a problem with my .CO.ZA domain it doesn’t propagate, It’s been 10 days and I have tried so many times, though nameservers and DNS are changed to point to infinityfree servers. This is my third .CO.ZA domain and I seem to experience almost the same thing though I have changed domain provider. Another .COM domain worked fine instantly hence why now I’m suspecting there should be something with .CO.ZA

From domain providers, they said it seems like infinityfree rejects it. Attached documents are my settings on my domain DNS & Nameserver

Thank you.

Since you did not provide actual info,
it is likely due to this


I don’t understand this I’m sorry. The information is provided above together with screenshot of my settings from my domain register. I need to figure out why though they’re set but still not working. screenshot No1 nameservers pointing to infinityfree server and screenshot too DNS configure for my site.

As you can read in the article:

Strangely enough, it seems that you were able to configure the nameservers, but according to your description, the settings have not taken effect.

Judging by this statement:

Which is explained by:

Note that in some cases, this limitation is not placed by the domain provider but by the registry itself. If so, the domain cannot be hosted here, regardless of which registrar you choose to use. It’s possible that .co.za domains have this restriction as well.


Thank you, Admin. Is it possible to check for me if that’s really the case? My consultants seem to be saying whatever to get through the problem. My domain is readhub.co.za . I would really appreciate your help. I’m really frustrated at this point, I don’t know what else to do.

Hmmm. I don’t see that they have been returned to the initial settings, but I see ns.epizy
(although there are more hops…)


but this system does not yet see the last NS set


This output likely means that ns1/2.epizy.com were added as NS records to the nameservers of IONOS. This is not recommended and it definitely won’t allow you to add your domain in here.

With all domain providers, there will be separate settings for setting the DNS Records of your domain and for setting the Nameservers of your domain. To use your domain here, you must update the Nameservers of your domain. You do not need to update your DNS Records, as those are irrelevant if you are using our nameservers in the first place.


I changed the DNS so I can add my domain as parked domain. My recent domain I bought them from IONOS and one of them propagated instantly which is www.zeusslago.com and it took the same process as I’m attempting with this one. So what would be the recommendation in this case?

Again: please read the article, it answers your question:

.com domains do not enforce strict nameserver checks on the registry level. Maybe IONOS does. If so, ask IONOS to fix this, or transfer your domain to a registrar that doesn’t unnecessarily restrict your ability to host your domain with a provider of your choosing.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.