CNAME Records Not Being Registered

Username, Website



Hello, I am trying to register an SSL so I can use https. In the control panel, I put the CNAME record it wanted, but when I went to check it didn’t work. I was curious, so I did a DNS lookup and there were no CNAME records registered to my site. I went to the control panel and they were there,but nothing I tried could find them. Please help, thanks!


Make sure that when you make the records, it follows this syntax:


That doesn’t explain why the CNAME records aren’t even being created.

If you don’t follow the rules, what do you expect?

1 Like

The InfinityFree SSL checker caches DNS records, so you will have to wait. It won’t detect the CNAME records as soon as you enter them.


I checked your CNAME records and they are working exactly like you configured them. If I do a DNS lookup for, I get the CNAME target you configured.

If you tried to setup the CNAME records for the SSL verification please make sure that the record name field contains ONLY the data from the record name field in the client area, it should NOT include your domain name as well.


It was automatically adding my domain name to the end XD. Thanks

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.