CNAME record not showing on SSL certificate renewal dashboard


I am having problems renewing my SSL certificate for my website

On the Renew Certificate Dashboard, it says that I have created an SSL order successfully. However, it also shows that my Current Destination is “Not Ready”, and I have “no CNAME found”, whilst at the same time my CNAME records show that I do have an existing CNAME record. See below screenshot:

If I press “Setup CNAME Records Automatically”, it tells me that “All CNAME records are already set up , no changes were made. Please wait for DNS propagation/caching.” I have waited for a day, tried again ad waited more than a day- it does the same thing every time.

What could I do to resolve this? Any ideas would be greatly appreciated :slight_smile:

You have to wait awhile for the DNS to propagate. Mine took 15-30 minutes when I renewed my SSL. It depends on what SSL provider you use, and how often your ISP refreshes the DNS (or whether they cache it or not). Just wait for awhile to see if it corrects itself. You can go back to “Free SSL Certificates” later to see if the page has updated. After it has updated, then you can install your SSL certificate.


What @solace-ken said is partially correct. The problem is indeed generally caused mostly by DNS propagation/caching.

The “Setup CNAME Records Automatically” button installs the CNAME records on your account. But the “Current Destination” field is based on the result of a DNS lookup done by the client area. This is to account for any issues or delays between the CNAME records being added to your account and them actually being published on the nameservers. Or any bugs or errors that happen in between.

I just checked and the DNS lookup results for your domain were a bit inconsistent, so it may take some time for the checks to go green and stay green.

This part is not correct:

  • The Current Destination checks are being done by us, nothing gets set up at the SSL provider until the check goes green and you click the Request Certificate button.
  • The check is being done from the client area servers, not your own computer, and neither are the validation checks done by the SSL provider. So the DNS settings in use on your internet connection are irrelevant in this case.

Thanks for the additional info. I appreciate it.

1 Like

Waiting did not resolve my issue unfortunately. I have waited for days now and nothing changes.
I should mention here that I recently had the following problem with the same domain: Why is one of my subdomain's CNAME "destination" set to advers? - #20 by Admin
I don’t know whether this could be part of the problem?

Seems all good to me now.


That looks good but I can’t see this on my side. I have not received an email that the certificate has been issued. When I visit the certificate, I see this:

Moreover, when I go to my Free SSL Certificates, I see this:

Could you please send me the link to the page where you can see this?

The screenshot from the admin just says that the CNAME is successful
and you have to click the button Request Certificate (to install the certificate)

also look at what you have under Pending or Draft


The current state of your certificate is Draft. You can see it if you click the Draft page.

Alternatively, you can just create a new order. If there is a pending/draft order with the same domain and provider, you’ll be redirected to that instead.


Thank you so much, this worked :slight_smile:


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.