Hi i have registered my domain adress directly in cloudflare because in control panel I get an error, but now, when I go to the control panel in the cloudflare option it say’s to me its disabled, and in cloudflare it says to me i need to change the nameservers, is it properly to change the nameservers?

If you are confused by the nameservers options, then I highly recommend to not use Cloudflare. Cloudflare can be a useful addon, or a great way to break your website if not configured correctly. To use Cloudflare, you need to be comfortable managing your own DNS records, and doing so is a lot more complicated than changing nameservers.

@Admin yes, but I want to try cloudflare, because of the ‘always https’ option, and for the ssl and I want to access it by https, I know i can use the rewriteEngine option in .htaacces but it says me that my page is not secure and I need to be in https to load properly my page

You can enable Cloudflare in the control panel OR switch your domain to Cloudflare’s nameservers (but then you’re responsible for maintaining your DNS records).

I get this LOUDFLARE ERROR : Sorry there was a problem activating cloudflare for this domain or the email address [email protected], this is normally caused by the email address or domain name already existing on the cloudflare system., and i think to directly add my domain to cloud flare, and change the name servers, but when I go to the infinityfree control panel, it says me cloudflare is disabled, i don’t know next steps

this is normally caused by the email address or domain name already existing on the cloudflare system.

In your first message you indicated you were confused by nameservers settings. You could only have seen those settings if you signed up with Cloudflare already and tried to add your domain to it.

Sounds quite self explanatory to me.

Unfortunately, this means the control panel integration is no longer an option for your account.

Ok, I don’t know what I’ve done but i have now the cloudflare certificate and the ‘always https’ option works fine, anyway thanks for trying support, now works fine the web :smiley: