Cloudflare Registrar and Addon Domain Validation

Hello everyone,
My user is epiz_26397201

I’m trying to setup my new domain with Cloudflare SSL and noticed that they now have a Registrar service, so I purchased my new domain through them. The problem is that for some reason they don’t let you change the nameservers for the domain like with every other registrar I’ve ever worked with.

I contacted Cloudflare to help me change the nameservers momentarily to and and this was their reply:

The short answer is that Cloudflare Registrar only uses Cloudflare name servers. For now.

If your hosting has cPanel, I’m surprised they have that restriction, as many people here use cPanel. I suspect they deliberately configured it that way.

If they won’t cooperate, your only choices are to either wait out the 60 day transfer hold and move your registration elsewhere, or host your site somewhere else right now.

As you can imagine, waiting 60 days is not an option and I really want to give InfinityFree a try, so what other forms of validation can I use?

Most hostings give you an option to create a CNAME or TXT entry which I could easily do in Cloudflare’s DNS.

I really wish I had known this beforehand and simply purchase the domain though Namesilo :frowning:

PLEASE give me a hand with this!

Many thanks in advance!

Hello there,

Unfortunately if Cloudflare won’t let you able to change nameservers for your domain then I guess you won’t be able to add that domain here on InfinityFree.

You might not be able to add that domain here on InfinityFree but I think you can still use that domain to point to a hosting account here, create a new or use an existing hosting account here and create your site on that hosting account and then create an A record for your domain from Cloudflare that points to the IP address of your site in that hosting account and your domain should display your site.

To find the IP address of your site, please refer here:

I haven’t tried this, but you can add NS (nameserver) record on Cloudflare DNS.

I tried your suggestion setting an A record to point to the IP of the InfinityFree server. Didn’t work.

I also tried setting a CNAME to point to the main domain of the server (, but both resolve to an iFastNet page with the following URL:

The NS records on Cloudflare didn’t work either. I can add the nameservers but it doesn’t seem to be doing anything at all.

There should be a way to validate an addon domain without changing the nameservers. Some hostings have the option of checking for a specific file inside the htdocs directory so you can prove you have control over the domain.Or like I mentioned before, creating a specific CNAME or TXT entry in the DNS.

Yes it seems like it would not work:

Our servers will only show your website if your domain name is assigned to a hosting account. Simply pointing it to the IP address or main domain of your account will NOT make it show your website!


Docs - InfinityFree Forum

1 Like

Alternative domain verification methods are on our wishlist. But until that’s done, you MUST be able to change your domain’s nameservers. If you can’t change the nameservers, you can’t use your domain with your current registrar.


Maybe tell about something like “It’s free hosting from ByetHost.”, “Only change the NS temporarily to validate my domain.”, & give screenshot (below, for example) to Cloudflare support team. they will consider it.

Then you can ask them to change it temporarily on behalf of you without domain transfer.
After your domain validated and can be added on your hosting panel, you can ask them again to change it back.

I already asked them a few days ago but haven’t received a reply yet. In the meantime I had to look for another hosting that let me verify the domain ownership without changing the nameservers. After the 60 day waiting period, I’ll switch from Cloudflare Registrar to NameSilo so I can verify the domain with InfinityFree.

Thank you for your assistance and hope to be back soon.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.