Clear Cache?

I’m getting 2 different results. I’m not sure what’s the problem but I believe it’s the cache?
Https version is showing outdated images and http is the current version.
I tried removing and readding the domain, also deleted the website and reuploaded it but somehow the cache is still there.
I turned off cloudflrare in Cpanel and went directly to cloudflare website and added my website and tried clearing cache but I’m not sure if that will do any good.
Is there anything that can be done on your side or if you can guide me ?
Help will be appreciated. Thank you!

I would be happy to check it myself, but your domain name is currently pointing to Cloudflare’s nameservers which doesn’t contain any DNS records for your domain.

Alright, I disabled cloudflare from cloudflare website and changed nameservers back to InfinityFree nameservers.
Website seems to be back online but both versions are now messed up.
Those images displayed on my website are not in my website images folder at all.
I’ve got Email from cloudflare after re-enabling cloudflare from Cpanel and I’ve purged everything from cache and changed cache expiration to 2 hours but is there anything that can be done on your side so the site looks updated?
Thanks once again!

Nvm it seems it is working now! BUT my favicon is still outdated on HTTP and HTTPS.
Also, how can I enforce HTTPS?

How to force all traffic to HTTPS:

The favicon being outdated is just browser cache, it will update itself soon enough for you too.