Checking up time with UpTimeRobot gives a 403 Forbidden

Website URL

Error Message

If I setup up time monitoring with UpTimeRobot the requests get blocked with a 403 Forbidden,
is there a way I can while list the IP’s or is that something InfinityFree has to do?

Other Information

here is a list of UpTimeRobot IPs’s Locations and IPs | UptimeRobot

Likely due to this


You may want to try hetrixtools instead


As others have said, using Hetrix tools should work. Or, you can just mark a 403 as a success, as that won’t show if the server is down.


But why would the server return 403 in response to the request of UptimeRobot?

1 Like

Poor configuration on their end??


I believe it uses js to redirect after the cookie is set, and uptimetobot doesnt run js ?

1 Like

But what does it have to do with the 403 status code?

1 Like

Probably something with the JS not being run, so the server can’t find that _TEST cookie. Perhaps the google redirect is blocked, as it goes outside the domain, so a 403 is returned? Or the IP is just blacklisted to prevent the uptime checker from being used as a cron service.


Apparently this is a good idea to prevent the reason why cron jobs got disabled (aka denial of service) from happening by blocking IPs in server level, not that the server still process such requests therefore can still go down by the sheer amount of requests even if it responds by 403.

Obviously I am unaware of how UptimeRobot processes things but if it is the reason then ifFastNet needs to do better than it.


Because the ?i=1 returns a blank html with js and cookies with a 403 status code, and uptimerobot just thinks thats the site response


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.