Change document root to /htdocs/public

Username (e.g. epiz_XXX) or Website URL

Error Message

Cannot find a setting to change document root to a subdirectory of htdocs.

Other Information

My site layout is like following:

/[root containing src, vendor, composer.json, etc.]
/[root]/[public] (Containg the index.php file and static files and images)

My index.php is located under a subdirectory of htdocs named public. The website has been designed in such a way that the document root must be set to public. Otherwise it won’t work. However, I don’t find a setting in CPanel or account settings to make this change.
Is there a way I can tell nginx or Apache on InfinityFree to assume /htdocs/public as the root of my site?

You can do this


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.